[UE4-27] AI Move To failing frequently in certain parts of the level

Hi all,

Been working with unreal exclusively through blueprints for a few years now and teaching myself as I go. I’m no expert, but I’m happy with my casual progress.
I was doing pretty well finding solutions to problems, but this one’s got me stumped.

So I have some AI that runs through a pretty standard behaviour tree.

If they see a player their location is set as the “TargetLocation” and then I use the MoveTo task in the BT to get the AI to move to that location.

Otherwise they are standing still or walking along a predetermined spline path.

If they lose sight of the player they return to their starting position or to the last position on the spline they were originally trying to get to.

When I made them in the test level everything worked great. They chased the player character, patrolled the path, reacted to damage and were defeated. Simple stuff. This is not a complex game.

I moved on and worked on other enemy AI and different parts of the game.

Now I’m making new levels I’m putting in these AI and a lot of the time they just don’t seem to work at all, or hit some sort of imaginary wall. Not only that, but they don’t react to damage received. They still take damage, but the character launch doesn’t seem to work on them.

I don’t believe this is a problem specifically to do with my blueprint or behaviour tree logic, because as I said, it WAS working earlier and in certain parts of every stage the AI can move without any problems.

And because it was asked in every question I saw that had similar issues, yes, I do have a NavMesh in my stage and the ground is green when I press P.

I tried remaking the AI from scratch and it ran in to the same problem.

I made my own “MoveToLocation” task where I could also put in some error messages for failures, but I couldn’t find a way to get any useful information on WHY it was failing.

Thinking it might just be an editor problem I packaged the game and tried to observe the AI in that. It seemed that some AI were able to move along their patrol spline a bit better than in the editor, but still couldn’t travel along the whole spline, froze when they saw the player and still were not launched after taking damage. Most of the AI behaviour didn’t change at all.

One AI that moves by jumping and then applying a force to their forward vector works just fine. They don’t use the MoveTo task at all.

It’s very possible something was accidentally enabled or disabled at some point as my cat does like to wander over my keyboard at bad moments. I would have no idea what it is though.

I’m not sure what to do now. This was working fine not too long ago, but now it almost doesn’t work at all. Any help is appreciated.

I could show you my blueprints, but like I said, I’m not sure the logic there is the problem.