[UE4.26] UE4 freezes my PC during launch and only hard resetting works

Since middle of December 2020 I can’t use Unreal Engine properly as the editor freezes my whole computer (data race maybe??). Even the task manager is unable to close the process, nor you can do anything at all. The only option it seems to be is that you hard reset the PC. I see similar issues had happened recently to others as well, yet no fix or resolution is proposed. Other product (game or application) are fully functional (no crash was observed which indicates that it is NOT caused by GPU driver or any third-party).

The crash re-occurs whenever you try to resize or move the window of the UE4 editor. I have the following hardware configuration:

ASUS Zephyrus S GX531GX_GX531GX
- Processor: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz   2.21 GHz
- OS: Windows 10 64-bit
- RAM: 24GB DDR4 2666MHz SDRAM	
- Storage: 1 TB M.2 PCIe 3.0 SSD
- VGA: NVIDIA® GeForce™ RTX 2080 8GB GDDR6
- Display:	15.6" FullHD (1920 x 1080) Wide View IPS
- Refresh Rate: 144 Hz

I managed to create a dump file from the frozen process and it shows the following:

 # Child-SP          RetAddr               Call Site
00 0000005e`a8f79d38 00007ffd`294ba34e     ntdll!NtWaitForSingleObject+0x14
01 0000005e`a8f79d40 00007ffc`e8a7ae9c     KERNELBASE!WaitForSingleObjectEx+0x8e
02 0000005e`a8f79de0 00007ffc`e825301d     UE4Editor_Core!FWindowsPlatformMisc::VerifyWindowsVersion+0x2fc
03 0000005e`a8f79f30 00007ffc`e82527dd     UE4Editor_RenderCore!FInputLatencyTimer::GameThreadTick+0x61d
04 0000005e`a8f7a0c0 00007ffc`d60fbb28     UE4Editor_RenderCore!FlushRenderingCommands+0x7fd
05 0000005e`a8f7a270 00007ffc`e7a5b035     UE4Editor_SlateRHIRenderer+0x5bb28
06 0000005e`a8f7a2a0 00007ffc`e7a27a9e     UE4Editor_Slate!FSlateApplication::PrivateDestroyWindow+0xe5
07 0000005e`a8f7a320 00007ffc`e7a72183     UE4Editor_Slate!FSlateApplication::DestroyWindowsImmediately+0x28e
08 0000005e`a8f7a400 00007ffc`e767aa61     UE4Editor_Slate!FSlateApplication::RequestDestroyWindow+0xf3
09 0000005e`a8f7a490 00007ffc`e7a27f1f     UE4Editor_SlateCore!SWindow::RequestDestroyWindow+0x131
0a 0000005e`a8f7a4f0 00007ffc`e7a2806c     UE4Editor_Slate!FSlateUser::DetectDrag+0x3cf
0b 0000005e`a8f7a540 00007ffc`e7a5c3f0     UE4Editor_Slate!FSlateApplication::DismissAllMenus+0xfc
0c 0000005e`a8f7a590 00007ffc`e7a502f0     UE4Editor_Slate!FSlateApplication::ProcessApplicationActivationEvent+0x50
0d 0000005e`a8f7a670 00007ffd`0972b5dd     UE4Editor_Slate!FSlateApplication::OnApplicationActivationChanged+0x10
0e 0000005e`a8f7a6a0 00007ffd`09719197     UE4Editor_ApplicationCore!FWindowsApplication::ProcessDeferredMessage+0x2dd
0f 0000005e`a8f7a960 00007ffd`0972dd2a     UE4Editor_ApplicationCore!FWindowsApplication::DeferMessage+0x177
10 0000005e`a8f7aa30 00007ffd`09714310     UE4Editor_ApplicationCore!FWindowsApplication::ProcessMessage+0x13fa
11 0000005e`a8f7af50 00007ffd`2adce858     UE4Editor_ApplicationCore!FWindowsApplication::AppWndProc+0x70
12 0000005e`a8f7afa0 00007ffd`2adce4ee     user32!UserCallWinProcCheckWow+0x2f8
13 0000005e`a8f7b130 00007ffd`060bf190     user32!CallWindowProcW+0x8e
14 0000005e`a8f7b180 00007ffd`2adce858     opengl32!glPushClientAttrib+0x15c90
15 0000005e`a8f7b1f0 00007ffd`2adce3dc     user32!UserCallWinProcCheckWow+0x2f8
16 0000005e`a8f7b380 00007ffd`2ade0bc3     user32!DispatchClientMessage+0x9c
17 0000005e`a8f7b3e0 00007ffd`2ba0fde4     user32!_fnDWORD+0x33
18 0000005e`a8f7b440 00007ffd`297c1064     ntdll!KiUserCallbackDispatcherContinue
19 0000005e`a8f7b4c8 00007ffd`2adca5c3     win32u!NtUserPeekMessage+0x14
1a 0000005e`a8f7b4d0 00007ffd`2adca523     user32!_PeekMessage+0x43
1b 0000005e`a8f7b540 00007ffd`0972f91e     user32!PeekMessageW+0x143
1c 0000005e`a8f7b5b0 00007ff6`822887e7     UE4Editor_ApplicationCore!FWindowsPlatformApplicationMisc::PumpMessages+0x13e
1d 0000005e`a8f7b670 00007ff6`822a113c     UE4Editor+0x87e7
1e 0000005e`a8f7d970 00007ff6`822a121a     UE4Editor+0x2113c
1f 0000005e`a8f7eac0 00007ff6`822b527d     UE4Editor!GuardedMainWrapper+0x1a
20 0000005e`a8f7eb00 00007ff6`822b7faa     UE4Editor!InitializeModule+0x23d
21 0000005e`a8f7fb60 00007ffd`2b527034     UE4Editor!InitializeModule+0x2f6a
22 0000005e`a8f7fba0 00007ffd`2b9bd0d1     kernel32!BaseThreadInitThunk+0x14
23 0000005e`a8f7fbd0 00000000`00000000     ntdll!RtlUserThreadStart+0x21

I noticed that UE4 freezes faster if the raytracing is enabled. It makes no difference when you change between Vulkan or DX12, the issue re-occurs after several minutes.

Please contact me if you require further assistance or information regarding the above issue.

Best regards,

Rajmund Kail
Software Engineer

i have the same issue so i would also appreciate knowing the solution to this

Please see the discussion here and see if it helps for you:
UE4 freezes my PC

Hello,

We’ve made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

Marinna

get the same problem after my windows updated to version 20H2 (19042.746)
had no prob with prev version , but not sure what one i had before, maybe 1809
in my case i get insta freeze within 5-10 seconds after opened my project, no idea how to fix it
RTX 2070

The official bug report form doesn’t seem to work at all. I have tried to report a very similar crash several times but nothing happens when I click the “send report” button. This problem is very severe and requires fixing.

They post this message when you place your question to “Bug Raport” category. In far in past AnwserHub was used for bug reporting, but it stream lined and move to separate site. Don’t know why they keep category is still here, but as said there form now for bug raporting. Also what you posted is not really a bug as it not reproducible and it is unknown if it’s a cause of UE4. Stack you posted seem top be form render thread there no main thread stack also if it fronze on Windows code

My UE4 editor doesn’t freeze Windows about 2-3 weeks ago. Last time I used Win+Ctrl+Alt+B to reset GPU driver when this occurred. I wonder if it was an NVidia driver or Windows update…

I had the same problem and managed to fix it a few minutes ago.
I’ll list the steps I took in order to do it:

  • Reinstalled UE4 v4.25.4
  • Reinstalled NVIDIA Studio Driver v461.40
  • Inside NVIDIA Control Panel, under Manage 3D Settings, in Preferred graphics processor, set to High-performance NVIDIA processor.
  • In WindowsUpdates, check for updates and install them all (this is what actually fixed it for me).

Hope this helps!