Download

ue4.25 Packaging project failed: Unable to use promoted target

I tried to package a game project. The packaging speed was very fast, and it was completed almost instantly, but no files were generated. I checked the log and only a few brief messages:



LogUObjectHash: Compacting FUObjectHashTables data took 0.82ms
LogMainFrame: Selected target: FPSGame
LogLauncherProfile: Unable to use promoted target-../../../../../Projects/UE4/SimpleFPSTemplate-UE-4.18/Binaries/Win64/FPSGame.target does not exist.


I went to that path to check, there is indeed no FPSGame.target file, only one FPSGameEditor.target file I tried to copy a FPSGameEditor.target file and rename it to FPSGame.target and then repackage the project, but it still failed and the log became:



LogUObjectHash: Compacting FUObjectHashTables data took 1.28ms
LogMainFrame: Selected target: FPSGame
LogLauncherProfile: Unable to use promoted target-receipt ../../../../../Projects/UE4/SimpleFPSTemplate-UE-4.18/Binaries/Win64/FPSGame.target is not for a promoted target


What does this “promoted target” mean? I originally built this game project with version 4.19 of Unreal Engine, and then rebuilt it with version 4.25. Is this problem due to the upgrade of the version? But I also tried to use 4.25 to create a new C++ game project, and found that its directory only has xxxEditor.target and no xxx.target file.

Please help me. This question has troubled me for more than a week. I have posted this question in many places without responding. On github, on answershub, on stackoverflow, on discord, etc., I found that one person also raised it and I have the same problem, but no one responded to him, and I don’t know if he solved the problem
His problem is here https://forums.unrealengine.com/unre…74#post1795874
My problem is here https://answers.unrealengine.com/que…6854/view.html
Please help me, please, I’m going crazy

More people are reporting the same issues. I’m really hoping for an answer as well. I’m trying to dig into it but I’m not getting further than OP really.

Same problem, same message, can`t package any project.

Did all of you report/submit as a bug? I did, but I think it’s much more likely they will have a look at the problem if more people do.

I cant read c++ code of blueprints either. Will try to update to the latest visual studio, maybe thats the problem.

can anyone help us

Someone gave a solution on answerhub, but it didn’t work for me, I hope this can help you, if you are also successful, please share this joy with me

https://answers.unrealengine.com/questions/976854/view.html