UE4.15 Plugin found in two locations


I’ve not been able to generate Project files for any project containing a plugin with Unreal 4.15. I keep getting the same error

ERROR: Found ‘TestPlugin’ plugin in two locations (D:\dev\UnrealProjects\PluginTest\Plugins\TestPlugin\TestPlugin.uplugin and D:\dev\UnrealProjects\PluginTest\Plugins\TestPlugin\TestPlugin.uplugin). Plugin names must be unique.

I already tried a blank new project, a blank plugin and a clean checkout of the engine. Does anyone know how to work that out? I would really appreciate the help since I wanna try out all the cool stuff that was added since 4.13 (which I’m using right now) and I don’t know what else to do.

Never mind. Apparently I did not clone the Unreal Engine Repo directly, but the fork, that I(?) or GitHub(?) made, when I joined(?). That fork seems to link to an older version of the engine, which did not even contain UE4.16. Once I cloned the right engine version, the error went away by itself. Follow up question: does anyone know how to update my fork of the engine? I have no use for this old a version…