Download

UE to Rigify Tool, unlock button destroys the animation

clicking unlock/unfreeze destroys my whole animation and makes many bones unanimated, any idea why or how to fix it?
also, when importing to UE4 the feet keeps rotating 360 degree in a weird way… thanks in advance.

ex:


Okay fixed it, so it turns out there’s 2 things that causes this:
1- Quaternion Euler in blender, UE4 doesn’t read it right.
2- Random bone scale (for some reason i found that some of my bones changes randomly changes scale decimals… don’t know if it’s caused by the UE tool or not).

So in order to fix this for anyone that faces this in the future:
1- I converted rigify current action from Quaternion to XYZ Euler (there’s a built in rigify tool for that in blender).
2- I selected all bones and removed the scales from them (in blender dope editor bar search for ‘scale’, select all keyframes, delete), then set to all bones scale keyframe of 1 at the beginning and end of the animation.

And yea, just another day wasted of debugging instead of creating :"D

1 Like
  1. is a know blender issue that the blender team has apparently ignored for now close to 2 years.

Hello @dinasorZ ,

We’re so elated that you were able to discover the solution to the issue you were having! :man_dancing:t4: I agree with @MostHost_LA , many game devs have had this issue with Blender. I’ve seen the issue reverberate through several forums. Would you mind uploading a video with the animation working correctly? Thank you! :smiley:

Thank you!.
The path between blender and unreal should really get much smoother than its current situation, we deserve to simply see the creations in Unreal just as they were exported from Blender without all these bugs…

Yes of course, here’s the animation working correctly and also re-upload of the buggy animation in better video quality. (These are prototype placeholders animations btw)

1 Like

The belnder issue is a blender issue though.
Has nothing to do with unreal or export/import.

It just introduces scaling when rotating bones.
I haven’t looked closely. And I have no idea why it does it.

All I know is that in my plugin I patched it by denying the rig from being able to stretch on a few key bones that produced overly visible results.
(Meaning it’s possible this can still happen on some arm movements).

Re the pipeline:

I tried my best with my pluign. It’s a one click export. Doesn’t get much easier than that.

The epic made plugin is just a bad concept.

Me, and the maker of Mr mannequin as well as a few others who had also made plugins, tried to explain several times why the choices being made ware a bad idea.

The end result for me is an unusable epic branded plugin.

And I honestly don’t care one bit, because I obviously use my own plugin :stuck_out_tongue:

If you need curves to export, I think, to date, my plugin is probably the only that does it…
(I honestly have no idea what kind of work people do when animating without exporting curves tbh. But apparently it’s not a sought after feature :man_shrugging: )

1 Like