UE Randomly Crashes A Lot

So I’ve been working on a project lately which was going okay, no problems with crashes or whatever.
But now, I can’t get any work done. It’s horrible! :frowning:

I guess there’s something I’ve done to upset the engine, or it just started to hate me out of nowhere but it crashes a lot out of nowhere. The crashes appear to be very random, it randomly happens while working on Blueprints, compiling, saving, pressing Stop after playing… It just crashes at any given moment, so I have no idea what the problem is.

I’ve got the crash report right here: Crash report UE4 - Pastebin.com

Hope you guys can help. And this reminds me I need to set up VersionControl asap…

Bumping to make sure it gets seen by the staff…

Hi Serellyn,

We believe this crash is related to one we have reported in UE-16935, but the call stack is slightly different so I’ve created a second report under UE-18697 to track it once the fix is implemented. We expect the fix to go live in 4.9 when that is officially released, but if you’re using a source build you can grab this change:

https://github.com/EpicGames/UnrealEngine/commit/40f9df8f06384b79dc8ed9ba37ce1a2b48c90f9d

or test the project in the Master branch.

It appears the crash is related to compiling and/or saving the AnimBP and/or the Character using that AnimBP, and possibly only if they reference each other in explicit casts. I’m not certain if you’ll be able to adjust these so that doesn’t happen, but it’s the first place I’d look.

Hope that helps!

Thanks for the info Ben. I don’t know what I changed but it spontaneously stopped crashing.

Sounds good! I’ll keep tracking this regardless. If you get that same crash again, feel free to let us know here. Thanks!

Hey Ben, it crashed multiple times again today, not sure if it’s because of the same error but here’s the log: MachineId:9011551A4B33D3F52DBF2491AADA1E62EpicAccountId:e75894d3c31b416eb7349b - Pastebin.com

That’s a different crash. When these crashes occurred, was it during Play in Editor? They appear to be a networking/replication crash; is this a Multiplayer game?

This crash is also already in our system (UE-16587), and it appears to involve seamless travel. Try disabling that in your GameModes and see if that crash ceases.

We have some reliable reproduction steps, but I’d like to hear any additional information you have so I can add it to the report. I’ll post here when I see any update on that.

I doubt it. That appears to be a logic problem, with what may still exist between levels that’s printing. We’d probably need to see it in the project to find the cause. If you’re able to determine it’s a bug, please feel free to open a new Bug Report post for it, though we may need to get a copy of the project to really narrow it down.

It’s indeed a multiplayer game. The most weird thing is that, after it crashed I restored it, and pressed play again to see if it would crash again but now it just worked.

There’s just one thing tho, since that crash (or around that time) I started to have very weird behavior on my Character Blueprint. I’ve described the problem here, might this be related? Print showing in Levels where it should not - Blueprint - Unreal Engine Forums

This engine just loves crashing and ruining our work it seems, the only thing its good at.
Just as I was progressing smoothly and after I moved a few files around and deleted some, it ruined my project and everytime I try loading up my blue print now it always crashes.

I started a new project and decided to move my assets one by one starting from my character and animations and it started crashing because of the animation import now which is strange, add better debugging options to solve such errors, I can’t do anything now, all my work is just lost??

I’m sorry if this sounds not nice, but at this rate I might just switch to another engine if the risks of this happening are lower.

Hello,

If you are experiencing a crash, please create a new post in the bug reports section and provide as much info as possible, including:

  • Your Machine ID and ensure to hit Send & Close on the report.
  • The logs from your project’s Saved->Logs folder
  • Repro steps if you have determined a solid repro case.

Thank you