Download

UE, Oculus and Steam not playing well together.

I have both a Rift and a Vive and therefore both sets of drivers/runtimes installed on my dev (and only) computer.
I am currently only using Rift + Touch for my project.

But I have a lot of trouble doing VR previews inside the Unreal editor.
Every other time it just displays black, or just hangs in the white Oculus waiting room, sometimes with a warning message, sometimes not.

I’m not sure what system is meant to take care of the VR preview display, is it Steam or Oculus?

Sometimes it seems like it is Steam running the show as I get the round floor circle. Other times it seems to be Oculus as the circle is not present.

It seems a terrible glitchy mess to me at the moment.

Does no-one else have these problems?

I tried uninstalling the SteamVR plugin from UE but then I didn’t get any VR option at all it was just greyed out.

Cheers
Fred

If you want to use the Rift explicitely, Exit Steam and SteamVR and, to be really sure its gone, kill the vrcompositor.exe if it exists in your task list.
If you want to use SteamVR explicitely, kill any oculus - process in your task manager and also stop both oculus services that are running (services.msc)

Worked for me.

Cheers,
Indy

Ok great thanks!
I’ll try that for a while and hopefully that will work for me too.

Cheers