UE Editor UI right-click bug in blueprint graph

Cannot use right-click to scroll the blueprint graph as seen here: Shitty Unreal bugs will be the death of me - YouTube

No steps to reproduce, it just happens.

Additionally the answerhub suggestion box often won’t go away and blocks the input field. Also it seems to forget the user was logged in. Fixing small things like this could make our lives a whole lot better.

Could you be more specific with your problem here. I watched the video that you provided but it does not offer a lot of information. What steps are you doing exactly to produce this. I do not seem to be having any issues navigating around Blueprints using right-click. Thank you.

Is there any other factors at play here that may not have been stated above?

Does this occur on a different computer? If you have a 2nd machine to test on I would ask you to try that and see if you can reproduce it there. Also just out of curiosity have you tried a different mouse, and do you have any other problems right-clicking outside of the engine?

I am asking this due to the fact that I am unable to reproduce this on multiple engine versions on multiple machines.

Thank you.

The information is in the previous post. To be specific:

  1. Cannot use right click to scroll the blueprint graph
  2. No steps to reproduce, it just happens

Sounds like a normal bug to me. Maybe get someone to debug potential causes, but it’s definitely happening within minutes of loading up.

@Antidamage: Are you using Plasma - KDE or any overlay software?

I don’t have a second machine to try it on.

There might be something - I’m enabling mouse cursor support inside my game controller. This only seems to happen after PIE, but it’s hard to say if that’s causing it.

I suspect it’s a rare problem, maybe just leave the issue open so other people can add to it.

No, this is on Windows.

I have some steps to reproduce it, at last!

  1. Create actor blueprint and add to world
  2. Open actor and create a function. Attach it to “beginplay” and turn on debug breakpoint for node
  3. Go back to editor viewport and hit PIE (not from blueprint window)
  4. Unable to scroll graph

This wasn’t the only failure case but it’s consistently reproducible.

Video: Blueprint graph failure - YouTube

I have followed your reproduction steps and still have not had any issues navigating the Blueprint graph when hitting PIE from the editor viewport.

Could you try closing out of all software that is running on your PC and then run the editor so that it is the only application open. If you are still experiencing problems please let me know. If this happens to fix your issue enable your other applications one by one until you find what is causing the problem and please let me know what was causing it.

Thank you.

Hey Jeff,

Sorry to butt in, but I saw the video and recalled having experienced the problem myself. I gave reproducing the issue a go and found that I hit the issue when doing the following:

First make sure that PIE window is ‘Always on top’. Can be set in Editor Preferences/ Level Editor - Play. For practical purposes disable ‘Always center window to screen’.

  • From a blueprint with a breakpoint, that will trigger when playing, hit the play button. This should create a new editor window for play.
  • When the breakpoint is reached, focus transfers to the blueprint, and the individual blueprint triggering the breakpoint is automatically selected as the debug object in the debug filter.
  • Do nothing, but pressing the resume button.
  • At this point the process resumes, but instead of clicking or mousing over the PIE window, attempt right dragging in the blueprint node space. This reproduces the problem for me at least.

Keep trying dude, this is killing me having to reload constantly. Once I use a breakpoint all graph scrolling project-wide dies.

Did you try turning on mouse click events in the player controller?

Edit: even with click and touch events off it still happens.

Hey SkyHigh,

I have followed the steps provided and I am still having no issues on my end. I have made multiple attempts to break the Blueprint navigation but have not had any issues. I have tried this on multiple machines creating new projects and testing this, all worked fine.

At this point I believe that the best option would be if a sample project could be provided that is already experiencing this problem for me to test.

Thank you.

Closing this ticket due to being unable to reproduce the problem and a lack in response. If you wish to reopen this please feel free to respond and provide a project that is showcasing this issue as I have been unable to reproduce it in clean projects.

Thank you.

This is the worst response I’ve seen on this site so far.

The problem is an editor bug and unrelated to a project. It’s clearly specific to a few people. You clearly won’t ever be able to reproduce it.

The right response is to file it with the developers and we all hope that they get around to it some time, not gatekeep it and close the ticket just because it’s not happening to you personally. That is the wrong way to handle a UI bug that has been demonstrated with a video.

Also, debugging is fundamental. I’d say that something wrong with debugging in the main product is near enough to critical to leave it open and pass it on just for the sake of it.

If I have no way to reproduce this then I can not send it up to any dev to look at. I have tried everything suggested by the folks here and nothing produced the issue that you are experiencing. I have also asked you to try closing all external software expect for the engine to see if that made any difference to which I never received a response from you.

Just because I didn’t reply to that suggestion doesn’t mean I didn’t dutifully try it. You don’t really explain what you mean by “software” which makes me wonder what you think you mean, but I closed down as many system tray and taskbar icons as I could. I left all my services alone though because that was a really poor suggestion. It turns out nothing was reaching into UE’s memory heap and deliberately altering right-click drag behaviour during debug.

Like I keep saying, you shouldn’t be gatekeeping a bug that all the actual developers know is probably not reproducible but is certainly able to be debugged by looking in the commit history for that functionality for 4.18. That’s why it needs to go to a developer.

Debugging is critical functionality. Just based on that keyword alone it should have progressed by now.

I also want to mention that you had a response to every post directed at me. As users of your service we really, really hate that cop-out. If I never heard it used to passive-aggressively close an issue again I’d be pretty happy.

Until reliable reproduction steps can be provided to generate this issue there is not much else that can be done here. What you have stated here has been tested internally between multiple different machines and people with no success in reproduction. The moment that I can consistently reproduce this a ticket will be created and sent to the devs to look at.

I also have this bug.
Compile and save does not fix it.
Restarting the editor does fix it.
I have reproduced this on 2 separate machines so far.
I haven’t tried to find the repro case yet as at first I thought it was just a random bug until I got it on my home machine as well. Will continue to look into why.

The selection box that forms, and prevents panning the viewport around, is originating from the near Event Pre Construct default node in the BP. If I move the node out of the way, the box still starts there.

All right click navigation functionality is lost in all other BP windows as well, but no selection box forms.
I have no breakpoints in my BP.

I’ve found additional effects (but still the same basic problem). When it’s happening it also affects the ability to use left click to drag UI widgets into a HUD graph. When it happened I went and checked right-click-drag in a normal blueprint and what do you know, it’s broken again.

This was outside of debugging and not during PIE, although I still think PIE is what kicks it off.


I also have this issue, as soon as I use a breakpoint I can no longer use right click and have to restart my entire project, however it seems to only affect my mobile versions of the project, I thought that maybe the “Use mouse for touch” could be the issue, but disabling it didnt affect the result.

However turning it off doesnt fix the problem.