UE does not take the full potential of the computer while rendering

I try to build a lightning in the interior scene, but over time the computer slows down and does not continue to render.

As you can see in the picture while building a light, the UE takes only about 20% of the CPU and the render takes so long.

Is there a setting to improve CPU lightmass building performance?