Download

UE 5 Nanite not working with imported meshes

Hello everyone,

I’ve been trying to import a couple of meshes from Zbrush and Blender in UE5 and I can’t seem to have Nanite working properly after enabling the option.

The mesh from Zbrush is about 450k polygons.
I tried to :
-enable nanite in the importe option and disable the create lightmaps option

  • checked that the option was enable in the static mesh window, and double checking that it was a nanite mesh by enabling vizualize wireframe ( the mesh disappeared which means it’s a nanite asset)
    -reclick on Enable Nanite when right clicking on the static mesh itself
    -Import a simple sphere from blender

The result is the same, no matter what distance the camera is from the mesh it doesn’t change the amount of polygon of the asset.
Next to the imported asset I have a quixel asset that works perfectly fine.

Could someone point me to what I’m missing here please ?

thanks in advance

Varte