UE 5 - Multi GPU Support - NOT SLI - NOT NVLINK

Very surprised UE 5 isn’t using more than my primary GPU for VRAM and overall processing etc. I’m coming from years of working in Davinci Resolve; each identical gpu added to the machine (without SLI or NVLink or anything like that), the system performance instantly increases by around 40%. DR will make use of the 2nd GPU VRAM and overall processing power.

Will UE 5 have the same capabilities?
I see my CPU usage absolutely max out in UE 5 - same with system RAM and VRAM on GPU 1.
But GPU 2 is untouched… GPU 1 is doing essentially ZERO processing, maxxing out VRAM, and GPU 2 with zero VRAM usage and zero processing…

Is there a plugin or something I can install to actually utilize all this hardware sitting here?
I get that PUGET SYSTEMS demonstrates that money is currently better spent on a 64 core CPU. But the performance gains I experience in Davinci Resolve with multiple GPUs is what I was expecting in Unreal Engine, especially this latest release.

4 Likes

so , i have the same issue!

1 Like

I want Multi-GPU support for UE5 as well. I want to be able to just add another RTX A6000 to my workstation when I want to upgrade instead of basically having to buy a whole new computer to upgrade.

Can anyone from Epic shed some light on multi-GPU plans for UE5?

4 Likes

I would like to see multiple GPU support. I have three GPUs and combined would have the VRAM needed for larger projects. Thank you.

Even if I have a single-gpu environment, this feature would be pretty nice for a modern engine.

I’m in the same boat, I have been trying to get Multi GPU running in Unreal since UE4 and it still not looking great in UE5. From my research there is a couple of commands targeting DirectX 12 mgpu but the engine just crashes when used in conjunct with ray-tracing or Lumen. The commands I found must be run on the .uproject which are:
“-game -d3d12 -MaxGPUCount=2 (or number of GPUs in your system up to 4) -AFR”
and if you want to test a multi GPU setup with a single GPU system you can add -VMGPU. I also found these console commands that you can add to your ini config file:
r.AllowMultiGPUInEditor 1
r.EnableMultiGPUForkAndJoin 1
r.PathTracing.GPUCount 2
D3D12.AFRSyncTemporalResources 1
D3D12.AFRUseFramePacing 1
r.GPUParticle.AFRReinject 1

An example if you want to try it on your system is to run this in CMD (Command Prompt):

“C:\Program Files\Epic Games\UE_5.0EA\Engine\Binaries\Win64\UnrealEditor.exe” “C:\Users\Public\Documents\Unreal Projects\UE5Test\UE5Test.uproject” -game -d3d12 -MaxGPUCount=4 -VMGPU -AFR

change the second path to your project file.

Also go to your project config folder “C:\Users\Public\Documents\Unreal Projects\UE5Test\Config” then edit DefaultEngine.ini if there is no [/Script/Engine.RendererSettings] section add it and the add:

r.AllowMultiGPUInEditor=1
r.EnableMultiGPUForkAndJoin=1
r.PathTracing.GPUCount 4
D3D12.AFRSyncTemporalResources=1
D3D12.AFRUseFramePacing=1
r.GPUParticle.AFRReinject=1

then try re-running the game in CMD again with the command above.

Your game might sometime boot up, flicker and then crash. If you do find out any other changes to make mgpu work please do share!

7 Likes

Perhaps it helps too!

1 Like

Also I saw this!

In the file:
“XXX\Engine\Config\ConsoleVariables.ini”

change:
; disable GPU Timeout
r.D3D12.GPUTimeout=0

Have tried multiple gpu in UE 5

Have you tired with multiple GPU with different machine in UE 5 ??

Did you make sure your GPUs are phisycally connected via an NvLink bridge? and SLI is activated in the Nvidia Control Panel?

EY GUYS!!!

  • Added support for multi-GPU rendering (mGPU). SLI is required. To enable it, pass -MaxGPUCount=2 on the Unreal Editor command line and set r.PathTracing.MultiGPU=1, which can be toggled at runtime. (r.AllowMultiGPUInEditor=1 is no longer required in .ini files to enable mGPU in the editor.)

It says SLI but…

Hi alberto, were you able to activate it? I tried that with no success

ey I’m not because I have not SLI :_