UE 5 crashes on launch "Assertion failed: "

I was using the dem version of UE5 no problem but when I updated to the new UE5 now It crashes immediately after launch with the following:
LoginId:d3e71161413c1539453ac8b498f02f12
EpicAccountId:be80633d6c594ce8a6ded2d038eb4dc4

Assertion failed: (TTraits::WithIdentical || TTraits::WithIdenticalViaEquality) [File:D:\build++UE5\Sync\LocalInstall\Engine\Source\Runtime\CoreUObject\Public\UObject\Class.h] [Line: 1476]

UnrealEditor_MegascansPlugin
UnrealEditor_CoreUObject
UnrealEditor_CoreUObject
UnrealEditor_CoreUObject
UnrealEditor_MegascansPlugin
UnrealEditor_CoreUObject
UnrealEditor_MegascansPlugin
UnrealEditor_CoreUObject
UnrealEditor_CoreUObject
UnrealEditor_CoreUObject
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Projects
UnrealEditor_Projects
UnrealEditor_Projects
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
kernel32
ntdll

any clues to what is going on? Should I delete and download it again?

2 Likes

I have this same issue.

I’m running on:

  • Intel Core I7 4790k
  • Geforce GTX 980 Strix OC
  • 32GB DDR3 Ram
  • installed on an m.2 mvme SSD
  • Windows 10

I’m reinstalling now the entire Engine and seeing how it works. After finished installing I reply again :slight_smile:

It seems updating the Engine from the Preview versions has caused this issue for some people, as William Faucher states on his video here in the pinned comment:

William Faucher
A bit of a bonus tip, if you’re experiencing bugs or crashes, ask yourself if you simply updated from Preview 1-2, directly to the full build. If you did, consider removing that, and installing UE5.0 again from scratch. It’s helped me and a few others. Good luck!

Good luck with the reinstall!

I reinstalled it. Now it works fine :slight_smile:

1 Like

Thank you for your tips, in my case I just had to update some plugins (Bridge) and it started working again, :grinning:
Thank you.

1 Like

Thank you very much! I have remove it and now it work (Ive had delete the whole folder quixel to make space but it was still referrencing it under ‘‘installed plugin’’)