[UE 5.2]Can't hide mouse when capturing

I’ve read all the answers on this and something seems to have changed in 5.2. When I capture the mouse, I can’t hide it. SetShowMouseCursor(false) does nothing.

Now, if I use SetInputMode(FInputModeGameOnly()), it does hide the mouse, but then I need to double click before I can interact with the scene. And using InputMode.SetConsumeCaptureMouseDown(false) does nothing.

So neither method works. Both methods above worked fine in 5.1. But In 5.2, neither one works. Anyone know how to get this to work?

Ok, I solved it. But I had to manually create Input modes. I kept thinking it was the usual culprit in setting the wrong capture mode. But no (well, yes in that needs to be used as well)… it’s not during capture, but rather when releasing capture. The FInputModeUIOnly input mode sets GameViewportClient.SetIgnoreInput(true); so the first click is ignored. This is NOT what we want.

So a custom input mode where it remains false fixed it for me.