UE 5.1 crashes if Shader model 6 is enabled

I have a few projects in 5.03 but nanite stopped trees from moving in the wind so I thought I would try 5.1. Now that I have updated to UE 5.1, I get a warning to enable Shader model 6. If I enable SM6 the UE crashes with a GPU error. There is plenty of GPU memory available. If I don’t enable SM6 and suppress the warning UE works ok.
I am using MSI Radeon RX 6700xt with 12gb and Ryzen 9 5900x with 32gb. win 11 pro installed. DX 12 ultimate has directxcap viewer shows D3D_FEATURE_LEVEL_12_1 and shader model 6.5.
I have updated window 11 pro and gpu drivers today with no effect. As a work around I edited the INI in the project directory to set SM to 5
How do I resolve the sm6 problem?
what effect will it have on my game if I do not enable SM6?

2 Likes

Try to verify Unreal Engine 5.1, and see if your graphic card need an update.
If that don’t work try to reinstall Unreal Engine 5.1.
If that don’t fix it, reprot it as a bug here:
https://unrealbugsubmissions.epicgames.com/s/

For me it is the same. It is definitely SM6, it crashes regularly, after 1-2 minutes flying around a level of mine. Log tells me there are problems with caches clearing.
SM5 runs fine.

GTX 1070
i7 7700k
Win10
16gb Ram
Samsung 970 Evo

I had the SM6-related crash on 6800xt too. Updating the driver to 22.11.1 resolved the issue for me (windows 10). Note that nanite no longer functions without SM6, nanite enabled meshes will revert to fallback meshes with SM5.

I’m seeing a virtual texture-related assignment editor freeze issue but otherwise everything is working (might be a localized issue due to some aspect of my project and/or system since I’m not seeing any other similar reports yet.)

Edit* Turns out the editor freeze issue I’m seeing is directly related to adding a second RVT volume to the level. Otherwise, 5.1 has been pretty solid so far.

I get crashes with SM6 when i use in project rhi Vulkan on windows 10. I haver gforce 1030

I got crashes with sm6 and directx 12 enabled gtx 1660Ti

when I said I had updated to the latest GPU drivers I was wrong. It looks like using the auto update in the AMD config app it does not get the latest, it only got to a version dated April 22. There are GPU drivers dated 24/11/2022 called version 22.11.1. As stated in e345spd’s comment, this version works with the shaders.
I would guess that the config software for the Nvidia GPUs are not giving the very latest version of their drivers either. So if this is happening on Nvidia you may want to check that there are any more later drivers.

Just updated a project from 5.0.3 to 5.1 for using nanite on vegetation. Activated dx12 and sm6, keep getting crashes saying im out of memory (3080ti gpu with updated drivers). I’ve tried reducing the render resolution to 100x100px just for testing and im still getting the same error. I think something is wrong with sm6 since in 5.0.3 i was able to render in 4k with 200 screen percentage.

Btw i have a 3080ti, 32gb of ram and an intel i9 10900k, drivers are up to date

I’ve managed to fix the issue by reinstalling the studio drivers and optimizing the scene (seems like the particle systems i was using was a “bit” heavy).

Hey ElrictheFirst. You have shader model 6.5 And i thing that’s the problem…

Nanite is working with Shader Model 6.6 atomics
Or Vulkan (VK_KHR_shader_atomic_int64

Check it here in Nanite Virtualized Geometry

I have the same problem. It’s time to buy a new laptop!