UE 5.1 crashes if Shader model 6 is enabled

I have a few projects in 5.03 but nanite stopped trees from moving in the wind so I thought I would try 5.1. Now that I have updated to UE 5.1, I get a warning to enable Shader model 6. If I enable SM6 the UE crashes with a GPU error. There is plenty of GPU memory available. If I don’t enable SM6 and suppress the warning UE works ok.
I am using MSI Radeon RX 6700xt with 12gb and Ryzen 9 5900x with 32gb. win 11 pro installed. DX 12 ultimate has directxcap viewer shows D3D_FEATURE_LEVEL_12_1 and shader model 6.5.
I have updated window 11 pro and gpu drivers today with no effect. As a work around I edited the INI in the project directory to set SM to 5
How do I resolve the sm6 problem?
what effect will it have on my game if I do not enable SM6?


Try to verify Unreal Engine 5.1, and see if your graphic card need an update.
If that don’t work try to reinstall Unreal Engine 5.1.
If that don’t fix it, reprot it as a bug here:

For me it is the same. It is definitely SM6, it crashes regularly, after 1-2 minutes flying around a level of mine. Log tells me there are problems with caches clearing.
SM5 runs fine.

GTX 1070
i7 7700k
16gb Ram
Samsung 970 Evo

1 Like

I had the SM6-related crash on 6800xt too. Updating the driver to 22.11.1 resolved the issue for me (windows 10). Note that nanite no longer functions without SM6, nanite enabled meshes will revert to fallback meshes with SM5.

I’m seeing a virtual texture-related assignment editor freeze issue but otherwise everything is working (might be a localized issue due to some aspect of my project and/or system since I’m not seeing any other similar reports yet.)

Edit* Turns out the editor freeze issue I’m seeing is directly related to adding a second RVT volume to the level. Otherwise, 5.1 has been pretty solid so far.

I get crashes with SM6 when i use in project rhi Vulkan on windows 10. I haver gforce 1030

1 Like

I got crashes with sm6 and directx 12 enabled gtx 1660Ti

when I said I had updated to the latest GPU drivers I was wrong. It looks like using the auto update in the AMD config app it does not get the latest, it only got to a version dated April 22. There are GPU drivers dated 24/11/2022 called version 22.11.1. As stated in e345spd’s comment, this version works with the shaders.
I would guess that the config software for the Nvidia GPUs are not giving the very latest version of their drivers either. So if this is happening on Nvidia you may want to check that there are any more later drivers.

1 Like

Just updated a project from 5.0.3 to 5.1 for using nanite on vegetation. Activated dx12 and sm6, keep getting crashes saying im out of memory (3080ti gpu with updated drivers). I’ve tried reducing the render resolution to 100x100px just for testing and im still getting the same error. I think something is wrong with sm6 since in 5.0.3 i was able to render in 4k with 200 screen percentage.

Btw i have a 3080ti, 32gb of ram and an intel i9 10900k, drivers are up to date

I’ve managed to fix the issue by reinstalling the studio drivers and optimizing the scene (seems like the particle systems i was using was a “bit” heavy).

Hey ElrictheFirst. You have shader model 6.5 And i thing that’s the problem…

Nanite is working with Shader Model 6.6 atomics
Or Vulkan (VK_KHR_shader_atomic_int64

Check it here in Nanite Virtualized Geometry

I have the same problem. It’s time to buy a new laptop!

It does have NOTHING to do with scene complexity. I created EMPTY project with box and light and it crashes after enabling SM6. It is engine issue, let’s report this as bug.


Exact same problem here, the editor works fine but if i activate SM6, i can’t launch anymore in standalone mode, it just instant crash.

If i rollback to SM5, works perfectly

I have a 2080Ti, 32Gb of Ram and Ryzen 5 3600XT

Similar issue here. Opened my 5.0.3 project and it says Nanite and Virtual Shadow Maps won’t run if I don’t enable SM6 in my settings. Without this, all of my textures are ruined and nanite is acting crazy.
Enabling SM6 gave me a loss in performance. Like from getting 80-90FPS in editor in 5.0.3 to getting around 70 in the same scene in 5.1
The real problem is Play in editor
The performance tanks. In 5.0.3 I had 60+ FPS but now hardly 15 FPS

Don’t know what to do. Will use 5.0.3 for now

1 Like

I am having a similar issue:
A scene that works perfectly in ue 5.0.3 can’t even load on 5.1
I have tried all of your advices up there, like:
-disabling SM6 and use SM5
-Trying DX11 or DX12
-Using developer nvidia driver
-Repairing Ue5.1 installation/uninstall and reinstall
-enable/disable Lumen global illumination and reflection
Nothing worked for me, I am having a memory error in this case about Ram cause it says the paging file is too small, I have tried to add more memory there but anything worked for me I spent 24 hours almost trying to get this working cause I think the foliage with nanite of 5.1 is needed.

My pc specs:
CPU: AMD Ryzen 7950X
GPU: RTX 4090
RAM: 128GB 6000Mhz

I mean I was able to use it in 5.0.3 without problem and with a very good fps now in 5.1 I can’t even load the Scene. I don’t think honestly is something about my pc specs I mean I am using very overpowered machine.
I went back to 5.0.3 I hope they will do something cause by reading around lot of people are experiencing weird stuff. If anyone can give me any other advice it’ s apreciated I will try and let you know

1 Like

I have the same issue , ue5.1 crashes instantly at launch with sm6 enabled (rtx3070 here). Is there any way to disable it in the config file somewhere ? Like this my project is lost , worked perfectly with 5.0.

Yes, in project settings in Plateforms → Windows, you can uncheck the SM6 option.

Btw, I “solved” the problem by disabling the plugin “Async loading screens”, since i have no more crash


also experiencing the same problems described in this thread. I was really hoping 5.1 would be a step towards some kind of reasonable stability.

1 Like

;im having no issues with5.1, double check your driver versions . Mine is working with gtx950 2gb and rx 6600 . UE5.1,no issues, so far;))

I’m also seeing weird blotchy here and there , textures,materials in 5.1, did going backi to 5.,0fix it ???

I mean for me back then 5.0.3 was totally fine. I will try 5.1.1 in a couple of weeks.