UE 4.9 hangs when launching w/ "-DX12" / "-D3D12" Parameters

Note: I understand that DirectX 12 is still in experimental stages and is currently unstable for production.

With the above note said, I am having issues launching the UE4Editor with the DirectX 12 parameter.
I am unsure if it’s an issue on my end, or if my current graphics card is currently incompatible with UE4 in DX12 mode.

System Specs:

  • OS: Windows 10 Pro (64-bit)
  • CPU: AMD FX-8350 4.0ghz
  • GPU: AMD Radeon R9 290 (4gb GDDR5 vram)
  • Chipset: AMD 990FX
  • RAM: 13gb DDR3

Scenario:

  1. I launch a shortcut on my desktop of the UE4Editor.exe with the DX12 parameter (“C:\Program Files\Epic Games\4.9\Engine\Binaries\Win64\UE4Editor.exe” -DX12)
  2. The Editor launches and brings up the window to Open/Create a project. I open my current project.
  3. The project loading splash screen appears, loading up the project.
  4. Once the splash screen disappears, the Editor seems to hang and I get a notification saying: “Display driver stopped responding and has recovered.” The Editor remains hung up in the taskbar and I have to kill the task to exit it.

If I launch the project without the Editor using the -DX12 parameter, it launches properly and without issues.

Things I’ve Tried:

  • Created a New Project while the UE4Editor is launched with the -DX12 parameter. Same issue happens with a new project
  • Used the -D3D12 parameter instead of the -DX12 parameter. Same issue persists.
  • Uninstalled the AMD Catalyst™ Display Driver version 15.20.1062.1004​ (Software Suite 15.7.1) using Display Driver Uninstaller (DDU), and updated to the AMD Catalyst™ Display Driver version 15.201.1151 (Software Suite 15.8 Beta). Same issue persists.
  • Launched the UE4Editor-Cmd.exe with the -DX12 to see if it’s not seeing the parameter properly. The command window starts up with the title: “UE4Editor.exe - DirectX 12”, so it is launching in DirectX 12 mode. Same issue persists on launching the project.

The only other thing I can think of doing that I haven’t already done is verifying that the 4.9 Engine installed properly.

I tried it out for myself and I can confirm. I have the same exact error with a r9 270x

Hi All,

We are aware of some of the issues launching with DirectX12. We have it in our system as UE-20622.

-Matt W.

couldnt run it on 4.9 too but
compiling the latest source 4.10.0 and making an own project and running in dx 12 is working for me.
But the 3d Viewport has artifacts and only in playmode its usable and artifacts free at least with an AMD r9 380.

Hello!
Yes Matt Williams but DirectX 11 haven’t any issue. It have been using since it releasing but yet no any issue came to know.

Are you experiencing the same issue as the original post?

Yes M. Williams, Absolutely I am experienced it.

Hey Matt.

AMD just released its Radeon Crimson Drivers today (15.11). After updating to these drivers, I opened UE 4.10 in DirectX 12 mode on a PC that uses an AMD R9 270 card. Then I created a brand new Empty project for testing, just to see if it would open. Success! I was able to open the project without a video driver crash.

Now I just have an issue with viewport artifacts in the editor.

However, if I play the game in the editor there are no artifacts, so I’m assuming it’s an issue with either my video settings/card or just an experimental issue.

TLDR: I recommend anyone having crashing issues with an AMD DirectX12 compatible card to update to the new Crimson drivers and try again.

Cheers!

Edit: As I’ve solved the issue to my own problem, I’m marking it as solved. Feel free to “unsolve” the answer if you need to.

Hey TankHo, and to anyone at Epic who sees this and hasn’t realized this yet. I’ve managed to determine that the artifacting is being caused by the Editor-specific primitives. (i.e. Charcter/FP capsule component, Post-Process/Lightmass Importance Volume Bounding Box, Movement/Scale/Rotation gizmos, AmbientSphereMarkers, Light markers, etc. And as a workaround (READ: Not a Permanent, or even viable solution depending on your workstyle.) You can go into the 3D viewport and in the top left corner (default), click “Show” > “Developer” > “Composite Editor Primitives” and uncheck that option if it happens to already be checked.

Hopefully that will get rid of the artifacts for most temporarily. It is probably important for me to note that disabling the “Composite Editor Primitives” option will also hide any kind of bounding box or in-leveling labels/markers that wouldn’t be seen during runtime. If you feel like its necessary, it’s always there to be reenabled if you need it. Just know that the artifacts will most likely return the moment you do.

This method was tested on Windows 10 Pro 64-bit running UE4 4.10.1 with D3D12 enabled. My CPU is an Intel Core I7-4770K at stock 3.5Ghz with all relevant drivers up-to date. My GPU is an MSI AMD R9 290 running in a PCI-X 3.0 X8 slot at stock frequency and the accompanying driver is the Radeon Crimson Edition driver. Here is my current drivers’ package version for those who’d like to compare results and alternative workarounds: 15.30.1025.1001-151204a-296874C

Hey Riley1389,

Could you open up a fresh Bug Report thread on AH for the artifacting?

-Matt W.