UE 4.6.0 and Oculus 0.4.3 huge bugs

Hi

There is so much wrong going on it so let me point out few things.

  1. I don`t know if someone has tested it but it is impossible to see something close. I got double images (it looks like the cameras are further away). In 4.5.1 everything is ok but not now. I was thinking that it was because the 4.6 Preview version but today I have downloaded the final release and it is the same.
  2. Huge drops. Don`t even try to use “HMD MIRROR OFF” it is killing Your FPS. In previose version everything is ok but now I need to have my mirror ON to have normal FPS.
  3. In the previous versions I got most of the time stable FPS, there were some drops but now I got almost half the FPS. 75 FPS are the same but in the previous version I got 65-70 FPS now it is down to 37.5. I know that there are bugs in the Oculus drivers.
  4. This bug was also in previous version but I will point it here out. You can`t use DirectoryTrack in Matinee with Oculus. It is giving You spikes when You will move Your camera even when You got 75FPS.

So if You are using Oculus, I would recommend to stick with the previous versions (Unreal Engine and Oculus).

Cheers,
Lucas

I also have experienced fps issues, I made a default project just to test it out (the really basic one with the chairs and tables floating in the sky). Right off the bat was getting really poor fps, the same number as you 37.5. I then entered into the console hmd sp 100, and then it was smooth as butter 75fps, but trying to go above 100 would always drop it back down to 37.5. And sometimes if I went back down to 100 it would still be stuck at 37.5. Hopefully epic can fix this.

When it does work it feels really solid though.

Also please add an option to remove the vignette, thanks.

Hey Illusionray-

We are investigating how 4.6 affected Oculus performance and frame rate (UE-6267) as this is a major concern. Thanks for the report and any other information or reproductions steps as to how you’re testing your fps will be helpful.

Cheers

Doug Wilson

same problem if fps going down 75fps, drop to 37fps

Having the same exact issues, UE4 4.5.1 and Oculus Runtime 0.4.2 I was hitting 75fps with settings cranked in Direct Mode launching from the editor. Rolled up to UE 4.6 and runtime 0.4.4 last night and duped my project and tried it out. Unless I face the corner, I’m averaging 37fps.

I tried the demo again in UE 4.5.1 and runtime 0.4.4 and it’s just about as bad there too, so I’m looking at the runtime as being the issue. I know that oculus made a patch for 4.6, I’m in the process of compiling that from Github to see if that makes any difference. After that I’ll try rolling back to 0.4.2 (I never tried 0.4.3). I’m wondering/hoping it will work like before with 4.6 because I’m really looking forward to the new 3D UMG features.

Hi

Well, we have a Dinosaur project will lots of stuff. We were optimizing it to hit 75FPS and we did it. The version we are using is 4.5.1 UE and 0.4.2 Oculus. The next version are getting worse. Oculus 4.3 had some black borderd and it is not something what we wanted but the performence was bad. Also with the newest UE and Oculus it is the same.

I found also why I got double image. It is because we attached the camera to a rotated object. In our project we have a MainCamera parented to a car and we are rotating in it. In the newest UE when You make something like this , Your eyes are getting separated. The head is rotating and the image also but You can clearly see that the distance between Your eyes is getting bigger. It is simple to test :slight_smile:

Cheers,
Lucas

Ditto: 37fps for me as well. My UE4 project was running 75hz locked prior to this (prior to updating to Oculus 0.4.3 runtime while simultaneously updating to Unreal Engine 4.6).
Note: This also affects my old UE4 deployments now (running Unreal Engine 4.3.1) so its definitely something with the Oculus 0.4.3 Beta Runtime.

Windows 7 Ultimate user myself.
I also downloaded and compiled Oculus UE4.6 fork (which uses 0.4.4 beta runtime) and that doesn’t even work for me (only when previewing in viewport) and I’m not the only one: https://forums.oculus.com/viewtopic.php?f=60&t=17715&start=20

Same here, i got terrible FPS after the introduction of the 0.4.3 Oculus runtime.

Recently i compiled the UE 4.6 GitHub version (compatible with 0.4.4), converted my demo and launched it with 0.4.4 installed, and i still have much worse performance than using the old 0.4.2…

I could run my scene at “hmd sp 140” on the 0.4.2 runtime, but i have to go down to “hmd sp 110” to have it playable on 0.4.3 / 0.4.4 (awfully blurry in comparison).

Since some people claim that it’s fine for them and since i used to have best performance with Windows AERO OFF (which gives 0 FPS with 0.4.3 and 0.4.4) i have a feeling that this might be related to Windows 7 and AERO.

Can the users that have reported here mention their OS version in order to prove/refute my theory?

Has anyone with Windows 8.1 noticed this reduction in performance?

Hi Doug, i believe the origin of this problem is the changes introduced on the 0.4.3 Oculus runtime to reduce overall latency.

This was reported about 6 weeks ago here:

I added as much information as i could in there, with lots of profile captures, logs, etc. I’m willing to run more tests if you need them!

Out of curiosity, do you know if Oculus/Epic can still run the Showdown demo at 90 Hz with the same quality settings and HW (graphics card) from Oculus Connect, using the latest 0.4.4 runtime?

As i mentioned elsewhere, if in the end this is the price that we have to pay in order to have lower latency and we can’t have both performance and low latency at the same time, then i would suggest to at least make it optional (something like ultra-low latency mode vs performance mode), or simply having some flag that we could enable/disable.

I am on Windows 7 Professional 64 bit with AERO off. Havent tested the new oculus with on since I am finishing an Oculus project and dont have much time :slight_smile:

PatimPatam: I found a fix that worked for me in your question.
Disabling SpeedStep in the Bios (CPU power saving technology) brought performance back to around pre-0.4.3 beta runtime for me (locked 75hz).

edit: Still I’m speculating though that it still nosedives to 37.5hz as soon as (real world) performance drops below 83hz as this happened with one of my other demos. Follow the question referenced above.

2nd edit: Not speculation anymore. Disasbling SpeedStep gave me better performance allowing my current demo to rise just above the threshold (believed to be around 83fps currently) for it to lock at 75hz. My older heavier demo which used to be 75hz is now 37.5hz however. :frowning:

In my PC there is no such thing like SpeedStep in Bios :frowning:

that not make difference in my computer.

with 0.4.2 i got 95-100fps in my demo, same demo in 0.4.3 75-80 and known i have 70fps

I missed it the first time I went through the Bios but eventually I found it under A.I → CPU Power settings.

Hey Wollan, like i mentioned in the other answerhub thread, this didn’t help much in my case.

Direct Mode + Aero OFF + Mirror OFF is the configuration that gave me the best performance pre-0.4.3 which just doesn’t work anymore, and the alternatives give me much worse performance in comparison.

Direct Mode + Aero OFF + Mirror OFF chops along at 1fps or less for me so totally unusable.

Yep that’s exactly what i mean when i say that it doesn’t work anymore.

This combination DID work on 0.4.2 and it gave me the best performance by far.

Done some more testing with my heavy demo(SpeedStep disabled):

Extended mode, UE 4.6 (official repo), ORv.0.4.3 : ~60fps
Direct mode: UE 4.6 (official repo), ORv.0.4.3 : 37.5fps

Extended Mode, UE 4.6 (official repo), ORv.0.4.4 : ~65-70fps
Direct mode: UE 4.6 (official repo), ORv.0.4.4 : 37.5fps

In general it seems like the requirements for UE4 has gone slightly up since 0.4.3.1 (using ORv0.4.1) where my heavy demo was running 75fps locked in Direct Mode. Using dynamic lighting, not static baked.

Hey Wollan-

Could you try something else for me? If you switch to Extend Desktop mode for the Oculus display and use the console command “hmd vsync off” do you still see the same numbers for your framerate? I would suggest trying this in both 0.4.3 runtime as well as 0.4.4.

Thanks