Download

UE 4.6.0 and Oculus 0.4.3 huge bugs

Hi

There is so much wrong going on it so let me point out few things.

  1. I don`t know if someone has tested it but it is impossible to see something close. I got double images (it looks like the cameras are further away). In 4.5.1 everything is ok but not now. I was thinking that it was because the 4.6 Preview version but today I have downloaded the final release and it is the same.
  2. Huge drops. Don`t even try to use “HMD MIRROR OFF” it is killing Your FPS. In previose version everything is ok but now I need to have my mirror ON to have normal FPS.
  3. In the previous versions I got most of the time stable FPS, there were some drops but now I got almost half the FPS. 75 FPS are the same but in the previous version I got 65-70 FPS now it is down to 37.5. I know that there are bugs in the Oculus drivers.
  4. This bug was also in previous version but I will point it here out. You can`t use DirectoryTrack in Matinee with Oculus. It is giving You spikes when You will move Your camera even when You got 75FPS.

So if You are using Oculus, I would recommend to stick with the previous versions (Unreal Engine and Oculus).

Cheers,
Lucas

Could you please make a post detailing these issues on AnswerHub (Bug Reports), Epic will want to know about any difficulties you are having with the new version, posting there will allow them to track the issue properly.

Thank you!

sure, it is done :slight_smile:

Thank you very much! :slight_smile:

Here is the link to the AnswerHub post for reference: https://answers.unrealengine.com/questions/141818/ue-460-and-oculus-043-huge-bugs.html

That’s weird! I’m very impressed with the new SDK integration. It works flawlessly here. Latency is extremely low in both Direct mode and extended mode.
I’m having no issues with matinees either.
EDIT: In the older version I would get 37.5 fps as soon as framerates got below 75. With the new version it only drops to ~70 fps.

This is better but still far away from 0.4.2 version. It was much better with the FPS. If there is a little drop thant You wont see much difference, but there are places where I got around 60 FPS on previous versions and now I got 37.5 FPS. But the biggest strange thing is that I cant see normaly im Oculus :slight_smile: I have a scene where I sit in a car and all the car inside is wrong. I see double image , same thing when You move the camers further away from each other. I had to switch to 0.4.2 to correct this. Also with the 0.4.2 I couldnt open 4.6 Previe (UE crashed before opening) so I am stuck with 4.5 UE na 0.4.2 Oculus. Didnt tested if the 0.4.2 works with 4.6 final release but I don`t see any reasons to switch version when there are more bugs for me :slight_smile:

Same issue here. Prior to updating to UE 4.6 and Oculus runtime 0.4.3 my Unreal project was running at 75hz locked.
Now it’s all 37hz (both my newly updated builds and my old UE 4.3.1 deployments) so UE4 & Oculus Runtime is clashing somehow.

Edit: I’m downloading Oculus fork of 4.6 with Oculus runtime 0.4.4 integration now to see if that fixes the issue.
https://github.com/Oculus-VR/UnrealEngine/tree/4.6
2nd Edit: Oculus 4.6 fork doesn’t even activate the DK2 and led light remains orange. Thread: https://forums.oculus.com/viewtopic.php?f=60&t=17715&start=20

I found a fix that worked for me in this question: 4.5.1: Capped at 37.5 fps in VR - UE4 AnswerHub
Disabling SpeedStep in the Bios (CPU power saving technology) brought performance back to around pre-0.4.3 beta runtime for me (locked 75hz).
Running Win 7 Ultimate 64bit w/Aero off. Hardware: i7-4770K, 16GB Ram, GTX780 Ti.

Cool that this worked for you Wollan (not for me unfortunately). But you are using Extended Mode i guess? (so no ultra-low latency i think)

Since the 0.4.3 runtime Direct Mode + Aero OFF doesn’t work for anyone i believe… What are your results with Direct Mode + Aero ON? Have you noticed an improvement too?

I am using Direct Mode On and Aero Off which is working fine now (having disabled SpeedStep). Currently compiling something so will have to wait with further tests.

Ooops sorry i forgot to mention in my previous post, are you using Direct Mode + Aero OFF + Mirroring OFF? (“hmd mirror off” after event “Begin Play”)

This is the configuration that gave me the best performance pre-0.4.3 which just doesn’t work anymore, and the alternatives (Direct Mode + Aero OFF + Mirroring ON / Direct Mode + Aero ON + Mirroring OFF / Extended Mode) give me much worse performance in comparison.

If you haven’t tried yet i would suggest going back to 0.4.2 and testing your demo with Mirroring OFF, i’m pretty sure you will get better performance than now.

i got better performance with 0.4.2/Mirror off clearly.

Testing my heavier demo:

Direct Mode + Aero OFF + Mirroring ON = 37.5hz.
Direct Mode + Aero OFF + Mirroring OFF = Image in glasses only updates once every second.
Direct Mode + Aero ON + Mirroring OFF = 37.5hz.

This demo used to be 75hz locked before.
I believe there’s something to that one Answerhub question (speculation in comments) that if realworld performance is below 83fps then it drops to 37.5hz. Otherwise it will be at the desired 75hz cap.

Disabling SpeedStep probably delivered just enough juice for my current lighter demo to rise above the threshold needed to lock it to 75hz.

Hello,

I’m dealing with this exact problem and I was wondering how you fixed this? Or did you find a solution at all? We have a skeletal mesh, it’s a vehicle like yours for all intents and purposes, and we fix the camera to a socket. 4.5.1 everything worked fine in VR, but now when we yaw our vehicle the double image issue occurs. The easiest repro is just start the map, yaw at 0 and it renders nice and clean, but as the root object is yawing the double image gets worse and worse. It appears, as you have said, that the IPD distance is growing with the rotation somehow.

Anyone else seeing this? In vehicle first person cams? Cockpit cams?

Also i should mention the camera we’re using is parented to a spring arm, which is parented to a bone in our skeletal mesh. UsePawnCameraRotation is set to true and our Pawn::GetViewRotation() function just returns the rotation from GetControlRotation()

I know it’s been mentioned in other threads, but please be aware that many of these bugs are with the Oculus runtimes, and not the engine directly. We tested our internal benchmark demos, and saw the correlation of framerate was tied to the revisions of the SDK rather than revisions of the engine. In extended mode, there was no difference between engine and runtime versions.

In direct mode in some configs, if you can’t maintain the 75Hz needed to maintain, the framerate might drop to 37.5 (half the screen refresh rate). We’ve noticed that if your config has issues with Direct mode, Extended mode is often much better. As Oculus revises their runtime, this should get much better!

Hi

@ShimShade - we made our project on 4.5.1 because of the drops, the IPD etc things so we didn`t bother about that :stuck_out_tongue:

While I would agree that Oculus Runtime is far from being flawless, I’d recommend to do further testing to figure out which part of integration is at fault. Just switch to Extend mode and see if you still get low FPS or if FPS is back to 0.4.2.
Locking at 37.5 fps could be caused by several reasons. One of them - is Intel SpeedStep technology that incorrectly decides that CPU has nothing to do and lowers the frequency. I’d recommend to turn it off in BIOS and re-test. Another reason: the game is unable to achieve 75 fps (CPU bound) and this leads to 37.5 fps (which is a way how SDK handles this situation). I’d recommend to try to enable parallel rendering (Nick W knows how to do that) and see if this changes anything.
We also have 0.4.4 + 4.6 (and 0.4.4 + 4.5.1) SDK integration available on github at https://github.com/Oculus-VR/UnrealEngine.
Even if you use UE 4.6 + 0.4.3 SDK, I’d recommend to install the latest 0.4.4 Runtime that contains newer and better video driver (yes, it will work with 0.4.3-based apps).
Answering to OP: I am unable to repro most of the issues, unfortunately. I’ve just synced to 4.6, re-installed 0.4.3 runtime and still don’t see these issues. I was able to repro the issue with the frame rate when ‘hmd mirror off’ is used, though. The bug report has been submitted.

P.S. I am not monitoring this forum, so if there are any issues with Oculus integration it would be nice if someone pings me or post on Oculus forum: https://forums.oculus.com/viewforum.php?f=60

Heavy demo results (SpeedStep disabled):

Extended mode, UE 4.6 (official repo), ORv.0.4.3 : ~60fps
Direct mode: UE 4.6 (official repo), ORv.0.4.3 : 37.5fps

Extended Mode, UE 4.6 (official repo), ORv.0.4.4 : ~65-70fps
Direct mode: UE 4.6 (official repo), ORv.0.4.4 : 37.5fps

With UE 4.3.1 using ORv0.4.1 my heavy demo was running 75fps locked in Direct Mode. I am using dynamic lighting (due to lots of imported material lacking UV mapping, originating from CAD). I know several new lighting features has been added since 0.4.3.1 so I need to re-consider my options but the lack of UV mapped objects limits me.

Curious about the parallel rendering option suggested.

Edit: Ran my older version of heavy demo (content practically identical, actually I had two Radiant UI webbrowser components in the scene running YouTube videos in addition):

Extended Mode, UE 4.3.1 (official repo), ORv.0.4.4 : ~70-75fps

I disable speedstep but its irrelevant for me.

I just want to report that I have same exact issues as the OP.