UE 4.4 Character animation broken on mac


Im using a 2013 running UE4.4

Since UE 4.4 animations are jerky at first but then freeze to a stand stil.

Here is a video of problem.


  1. I create a new third person blueprint
  2. start a game and animations are jerky.
  3. third time i start game animation is frozen.

I noticed this when i converted a project from 4.3 to 4.4. And I noticed that problem is same when starting a new project in 4.4.

Do you know what could be wrong?

I use Mac OS Yosemite 10.10. I have also tried it on a 2013 imac.

I forgot to say that it works fine in 4.3 with same hardware and OS.

Hey ,

We don’t support 10.10 yet. Have you seen this on a Mac with 10.9?

Ok. I’ll stick to 4.3 for time being then.

Both my mac’s run Yosemite 10.10. So I can not test 10.9 i’m afraid.


We’ll take a look and see if we can reproduce it using 10.9.4. I will let you know what we find.

Thank you!

In meantime i can supply specs of my hardware if that helps:

15" 2013
Memory: 16GB

iMac 27"
Memory 12GB

I wasn’t able to reproduce issue in a new 4.4 Third Person template project. You’re seeing player character’s animations freeze after you PIE a few times? Does character still move, just without animations? Does freeze continue indefinitely? If you click in Viewport while Playing, do animations remain frozen?

If you wouldn’t mind, it would also be helpful to see logs for this project after this happens. Thanks!

I just tried animation.umap in content examples for 4.4.

That looked really wierd.

See video:

Yes, i can move character around but animation has frozen. Some times it, after a longer time, move a frame in animation and freeze that instead. Like a very slow animation.

I will supply log

Ouch. Yea, that looks like it might be a 10.10 issue, but I’m going to run this by Mac developers once you post your logs and we’ll make sure it isn’t something else.

Heres logs for Third person blueprint project and animation.umap in content examples.

link text

Out of curiosity, can you provide system profiles for one or both of Macs, using /Applications/Utilities/System Information.app? That gives us more details to work with.

Also, can you try seeing what framerate is in editor for 4.4? From main menu bar > Unreal Engine > Preferences… > General > Miscellaneous > Performance > Show FPS

It seems a bit odd that 10.10 beta is causing animation to fall over in 4.4 and not 4.3. I’m not aware of any changes we made that could explain that at all.

Sorry for not reporting back on this.

I will try things you suggested.

I have also tried new Yosemite Public Beta 2 and UE 4.4.1. But problem is stil there.

Ok. So now I have more information.

My has double graphics cards. One integrated Intel Iris Pro and One Nvidia GT 750M.

When I switch to Intel Iris Pro it works!!!

When I switch it back to Nvidia GT 750M problem is back.

(my imac has a Nvidia GTX 775M)

So maybe there is a problem with graphics drivers for Nvidia GT 750M and GTX 775M in Yosemite?

Info on Nvidia:

Chipset Model: NVIDIA GeForce GT 750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 2048 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fe9
Revision ID: 0x00a2
ROM Revision: 3776
gMux Version: 4.0.8 [3.2.8]

Hey nexus,

Have you upgraded to 4.4.2 yet? Does issue persist with latest version of Yosemite and 4.4.2?


I just tried 4.4.2 but problem is same.

Works fine with Intel Iris Pro but not with Nvidia GT 750M/Nvidia GTX 775M.

I will investigate if nvidia drivers is changed in yosemite.

Thank you. Please let us know.

I have a same problem in my (mid 2012) :frowning:

I use yosemite DP7 and 4.4.2…

Pin_E: Whats your graphics card brand and model?

NVIDIA Geforce GT 650M and Intel HD Graphics 4000.
In intel graphics, it works so fine but geforce has a problem.