UE 4.4.3 + Rift DK2 + Mac OS 10.9.2 = No Go

I just read a comment saying DK2 support on Mac was added in 4.4.1, which I found confusing, because I don’t see it.

I’ve been trying to load VR templates and Couch Knights into the Rift from UE4 Editor, with 0 success. OS X 10.9.2 (Mac Pro + Radeon 7950), UE 4.4.3.

I tried to enable stereo rendering through the console, but motion tracking never works, and if I try to load Standalone (not windowed) it crashes the system, forcing me to reboot.

Is there a way to add a “Play” option to feed it directly to the Rift? Or am I forgetting something?

Hi TheNoize,

I posted this on the forum thread as well, however I wanted to make sure I posted it here as well:

“I did a little digging and found our DK2 instructions, located here:
On a Mac, you will need to roll back to 4.3 to be able to use the DK2.”

I will mark this as answered for tracking purposes.


Nah, 4.3 crashes just as spectacularly. Same thing.

Hey TheNoize,

Did you install the Runtime? If so, you’ll need to remove that from your Mac, as it causes head-tracking not to work.

Hey TheNoize,

We haven’t heard back from you in a while, so I am marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please let us know if you have tried uninstalling the DK2 Runtime. If you are getting a crash, please zip and attach the crash logs and dump file for your project after a crash. You can get information on where to find those files here: