UE 4.24.1 - VIVE/Index - No Motion Controllers Detected

Before I submit a bug report I wanted to see if anyone has seen this issue. Essentially I get no response from the VIVE and Index Motion Controllers in UE 4.24.1.

I’ve never seen this issue before. I made a blank project to test. It doesn’t matter if I migrate previous VR Pawns, use the default UE4 VR Template or try to make a simple VR Pawn from scratch, the Motion Controllers aren’t detected and don’t track and don’t generate inputs. They’re meshes are visible in the level at their default locations.

The Motion Controllers are working as expected in Steam VR and all previous versions of the UE4 editor.

I can only assume this has something to do with the new implementation of “SteamVR Input” but I haven’t found anything to suggest why my controllers aren’t tracking in UE4. SteamVR Plugin is enabled.

Anybody run across this or have any ideas before I submit a bug report? I also tried a clean re-install of 4.24.1.

I have the same issue, except the VR controllers disappear entirely when I test my project, both in the preview and when I export it as a standalone game. When I rolled back to any of the previous versions, the controllers appeared as normal, but the spectator mode had a resolution that was larger than my monitor (the latter issue was solved by updating the engine). I think this has to do with how the old motion controller input variables were deprecated for individual variables based on different headsets, though the Vive inputs generate errors saying that they are not blueprint bindable.TDespite this, the controllers show up in the steam VR home and in other applications except for the one that I am making. I am very new to using Unreal, so I am not sure if my logic is correct.

Thanks for your reply itspeng1.

I just opened my project to do another round of tests and for some reason my motion controllers started tracking again. I didn’t change anything in the project since yesterday when I made the post.

I have no idea why this happened. Was there a new SteamVR update that auto-updated? Was it just the act of restarting my machine? I will report back if I see any more issues…

Hi, I had exactly the same issue, Vive Pro controllers and Cosmos controllers weren’t tracking my movement, just stayed on the same place on the floor - only in packaged project, in editor it was working. Luckily I found the solution.

When you create VR project in 4.24, go to Config folder and you will see folder called “SteamVRBindings”. From 4.24 this is where all input bindings are stored and used with Steam Input I guess.

After packaging the project, you need to go to the folder of packaged project “WindowsNoEditor/FolderWithNameOfTheProject/” and there you need to manually create “Config” folder and copy-paste “SteamVRBindings” folder there. So if your Project is called “VRProject”, you will have “WindowsNoEditor/VRProject/Config/SteamVRBindings”. After this, controllers were working again.

If you need to change Input bindings, go to “Project Settings / Input” and change them. But after that, you need to click on “SteamVR Input” button at the top bar (next to Blueprints) and click on both “Regenerate…” options and “Reload…” option. This will update files in “SteamVRBindings” folder and you need to copy this folder again to your packaged folder as I described above.

Hope someone will find this useful. Cheers.

I had a similar situation happen. No tracking after updating to 4.24 with the new integrated SteamInput plugin. Posting my solution up in case it helps anyone.

In my case, I had been using the older plugin from Github. I had existing config files from the old setup. The solution was to clear the read only flag that came from source control. After that all the files could be written and it all worked correctly.

The logs are a bit spammy with a log message for each input mapped, so the errors melt into the 40 other ‘registered action’ messages.

Still having the same issue. Steps to reproduce - 4.24.2 - Create VR Template - Play in VR. Controllers are not being tracked. Has anyone figured out how to solve the issue?

try updating to 4.24.3

Fixed! UE-88548 GitHub 6680 : SteamVR Input Hotfix 3 Candidate Fixes

I just submitted this as a bug, but I thought I’d chime in here as well.
In 4.24.3 I can get the Index Controllers and buttons working, except the thumb sticks. They always return 0 no matter how far I’m pushing them. Clicking them in does work, its just the thumb sticks movement on the Index.
My oculus thumb sticks work fine.

Similarly, in version 4.24.3, my cosmos device is unable to input the rocker value normally. All other contents are valid, but the rocker return value is always 0, The fix for VR in version 4.24.3 didn’t solve the problem of cosmos. I even tried the latest version of 4.25, which still exists. As a result, the development of cosmos devices is almost unavailable in versions above 4.24;