UE 4.20.2 Handheld AR template compiling but not running on any IOS device

I seem to be able to compile a Handheld AR Template App using my MAC, and it Packages too. However, the application will close right after opening. If I try to Launch, it will return Error=0 right up to the point of deployment but the app will never open. I checked my iPad Pro’s Crash Logs using xCode10 and this is what it says:
link text

So basically the App is crashing. I tried both iPad Pro and iPhone . Also, ran other UE4 templates and everything works as expected so the problem is only Handheld AR Template in IOS. I had also tried compiling on Windows for Android and Handheld AR template worked like a charm. Is there any solution to this problem in IOS?

Found the issue. According to Handheld AR Template Quickstart | Unreal Engine Documentation HandheldAR template is supposed to configure and enable the Apple ARKit Plugin for you, but it doesn’t. So it was just a matter of clicking “Enable” and restarting the Engine.

I just found it a little weird that it gave no compilation, packaging or launch error.

Exactly that. It’s insane that they released it as a template and made it officially part of the engine but forgot to have the plugin enabled by default when that project is created! OOPS!