Download

UE 4.15 - Sharp skybox (NoMipmaps) problem.

Hi,

I´m having problem with my testing skybox. What I want to achieve is sharp skybox but I´m getting strange results on all materials when I disable mipmaps on the skybox. I´m using 32bit hdr but I´ve tried also 16bit but still same. I´m following this tutorial: http://rag3dviz.com/tutorial/hdri-lighting-in-unreal-engine/2/. I´ve tried also rebuild whole solution and different UE versions but still without changes. See video below that explain what I mean exactly.

https://youtu.be/TtWOLGsMSNI

I would be really happy for any suggestion.

Thank you.

Roughness/dullness in reflections is based on uing mip levels – the rougher the surface, the blurrier the mip it chooses. Because you turned off mips and are also using a blueprint showcase component that (I’m guessing) sets an ambient cubemap or skylight override texture based on the same texture you feed to the skybox, when that texture no longer has mips available every reflection has to use the sharpest mip level and they begin to always look shiny.

Try it with a normal skysphere and a skylight that does its own reflection capture and see if that fixes it. It won’t matter then if the texture on the skysphere is unmipped, because it will be recaptured by the skylight and mip levels will be generated for the reflections only.

You should still be careful with this; temporal AA is going to make up for the undersampling of the sky that is going to happen without mips, and it may cause a lot of extra ghosting when an object moves past the sky, depending on how extreme you go with this and how many high frequency features are in your image.

Isn’t there a way to use mipmaps on skybox, but force sky sphere to always have original mipmap image. Maybe this way reflections will keep using proper mip levels, while sky sphere will use mip level 0 ?

Yes, he could set ‘const mip value’ in the details panel on the sampler node in the material, and then reenable the generated mips in the texture so that they can still be used in the ambient cubemap or skylight override texture, if that is where the problem is.

Thank you for your reply! I will try your tips and let you know if it helps.

I’ve tried to use regular BP_Skysphere and it works well but I found probably the root problem. It happened when I had Post Process with enabled Ambient Cubemap and with NoMipmaps HDRI settings. I had to duplicate my HDRI and use them separately. One for BP_Skysphere (NoMipmaps) as skybox and second for increasing HDR intensity on the landscape (Ambient Cubemap in Post Process) with mipmaps. I’m not sure if this is right way but it works for me. Without PostProcess I have my landscape too dark.