UE 4.14.x OpenGL ES Deferred Reflection Broken

hi, i’ve been using nvidia shield to do archviz in some time now since UE 4.9
i’m using source build from github.

until UE 4.12 i have no problem packaging my projects into shield with OpenGL ES31 + AEP
everything just works.

however since UE 4.13 Epic separate OpenGL ES31 and AEP and rename it into OpenGL ES Deferred,
i couldn’t even build UE 4.13 with OpenGL ES Deferred, i always got error in MS Visual Studio 2015.
so i keep using UE 4.12 for a while.

when UE 4.14 released i tried to build the engine again hoping OpenGL ES Deferred is working.
the engine did completed the build process, and i’m happy using it. since it got many nice new features like automated LOD generation which is helping so much with deploying into Nvidia Shield. but then this reflection problem came.

so far i tried to build from source from 4.14.0-4.14.2 and the problem still there.

i attached screenshots from my shield:

how it should looks like (screenshot from editor):

in shield screenshot all reflection capture didnt work, result is black. i don’t know if IES spotlight didn’t show up in other two light is part of them problem.
it was working fine in UE 4.9.x-4.12.x
so i’m wondering if this is new bug

by the way if i tried packaging with OpenGL ES3.1 alone without OpenGL ES Deferred, reflection is working, but graphics quality is like OpenGL ES2 with improvement just more texture slot, and that’s not for me.

I need OpenGL ES Deferred for high quality rendering with temporal anti aliasing, post processing, deferred decal and such for my archviz.

so if anyone can help me it will be very helpfull.
thanks in advance.

Step to reproduce:

  1. using realistic rendering example (tested in other example like Reflection Subway and even in new blank project with simple reflective floor and some primitive objects and reflection capture)
  2. build UE 4.14.2 from github with changes: bBuildForESDeferred=true
  3. make sure BuildForESDeferred is ticked in project setting
  4. using android-21 for NDK API Level (tested with android-19 and android-23 with same result)
  5. using Nvidia CodeWorks for Android 1R5
  6. package the project using Android_DXT (for tegra)
  7. run in device and all reflection is black