UE 4.14 "Enable HMD" VR not working on "Launch Game" command

Hey guys,

To test the game, I usually close the editor, then “right click” on my game project file and choose “launch game” to test the in-game FPS without the editor load. Ever since the 4.14 update I get a black screen when I switch from desktop to VR HMD with the command that I registered in the Main Character Blueprint (see below).

I have the Oculus CV1 and a GTX 970, I installed all the latest drivers from Nvidia and Oculus.The problem persists on both the CV1 and the DK2.

The forward shader option in the project settings is enabled, but it happens even when this option is disabled.

To check the issue in a new project do the following steps:

  • Launch the engine and create a VR or third person template with starter content
  • Open the Character Blueprint Add an “input -” node and connect it to a flip flop (see below).
  • Create two nodes with “enable HMD”, one of them enabled the other disabled and connect them to the flip flop
  • Build, save and Close the editor
  • Right click on the project file —> launch game ---->wait for it to load
  • click on the button that you registered as “input -” node to switch to HMD
  • Observe the screen going black and no image on your HMD
  • Commands such as “stereo on” or “Enable HMD” in the console won’t work either

The internal editor “play in VR” mode works flawlessly, but I wish to test it without the editor load, so I can get an accurate estimate of the FPS and prevent motion sickness from constantly testing the world in VR.

Does anybody else experience a similar problem? I would really like to stay on 4.14 because the forward shader is a great asset of this engine version.

I’m not fully sure what the problem is for you but this might help.
Either way, others with similar problems may be happy of this answer/redirection, cause I got to this question by trying to solve my problem.