[UE 4.14/4.15]Compile Link Error Steam SDK v1.37 - Latest Version (v1.39)

A problem occurred while I was looking through Steam sdk to register a game in Steam.

This document said, “For legal reasons, using Steam requires downloading the latest SDK from Valve.”

So I checked it.

The steam SDK in Unreal Engine is v1.32.
The latest version of steam SDK is v 1.39.

I downloaded the latest version from steamworks and referred to the below document.

But this compile error occurred.

I tried to find lots of text messages from the community and Google, but I couldn’t solve them.
So I tested the version below in order.

Latest Steamworks SDK released 1/6/2017: Download the Steamworks SDK v1.39

  • Download the Steamworks SDK v1.38a, released 10/19/2016
  • Download the Steamworks SDK v1.37, released 05/23/2016
  • Download the Steamworks SDK v1.36, released 02/09/2016
  • Download the Steamworks SDK v1.35a, released 1/15/2016
  • Download the Steamworks SDK v1.35, released 10/20/2015
  • Download the Steamworks SDK v1.34, released 7/28/2015
  • Download the Steamworks SDK v1.33b, released 5/19/2015
  • Download the Steamworks SDK v1.32, released 2/5/2015

It was okay until v1.32 ~ v1.36,

From v1.37, the above link error occurred.
There was a changed content from 1.37 to steam_api.h.

I can’t make progress from here.Help me.

Is it possible to register the game in Steam Store with v1.32 which is included in unreal engine?

Somebody help me~ ㅜ_ㅜ

Hello ,

I would suggest taking a look at the information on the thread that I have provided below. I hope that this information helps.

Link: Steam SDK versions in 4.13 - Platform & Builds - Epic Developer Community Forums

Make it a great day

Dear Ruby Triplett

Thank you !! Thank you for your reply. But I couldn’t solve the problem even with the method you explained.

There is no problem in executing the program in Unreal Editor.

But when I do VS development or shipping build, steam sdk link error occurs, so packaging is not possible.

Is there any solution for the this problem?

I am also having the same problem with linker errors with a blueprint project.

I’m using Unreal Engine 4.15.1 and Steam SDK 139, all the steam features seem to work fine when I run my project in the editor but it fails to build with the same linker errors as OP when I try to package the project.

My project also builds fine with older sdk’s.

After doing a bit more digging I found a post that I believe may help. I have provided it below. Could you try the solution found at the link below and let me know if this works for you?

Link: What's wrong with my steam settings? - C++ - Epic Developer Community Forums

Sorry for the late reply

Yes that seemed to have worked, I successfully managed to compile my project with steamworks sdk v139 using the method from the link you provided, thank you =)

A small note to anyone else that stumbles across this topic, in the link provided “Takylucid” says to use the original “steam_api.dll” and “steam_api64.dll”, its actually the 2 .lib files “steam_api.lib” and “steam_api64.lib” not .dll.

Steps I took to compile with sdk v139

  1. backup the current “steam_api.lib” and “steam_api64.lib” that come with your unreal engine install located in “Unreal Engine\UE_4.##\Engine\Source\ThirdParty\Steamworks\Steamv132\sdk\redistributable_bin”

  2. install the steamworks sdk as normal

  3. then copy the 2 .lib files back and it should work

Is this safe using the older .lib files with a newer sdk?

After a little more testing it seems using this method causes linker errors when trying to package a project if I include the advanced sessions plugin