Download

UE 4.13/4.14 VR with sequencer playback in slowmotion

Hey Guys,

I made a VR project in Unreal 4.12.5 and it’s based on Sequencer. the whole sequence is 2 minutes. so when I play in in VR inside 4.12.5 it plays back fine. Then I migrated to 4.13 and everything works, except when I play in VR the playback speed is dependant to the fps… So when the fps drops it plays in slowmotion! so it plays back 2 minute sequence at around 4 mins !

Has any1 else encountered this issue ?!

It’s strange because it used to be ok in 4.12 but in 4.13 the sequence playback is not in fixed speed.

Update: The problem still exists after migrating to 4.14!

Hey!
I’m also making a VR experience based on sequencer in 4.13. I have not run in to this problem yet. But probably will. Please keep us posted if you solve it :slight_smile:

I had some strange speed things happening too when using the timeline.
I had “Use Fixed Frame Rate” checked and set at 90 fps - under Project Settings > General Settings. When I unchecked this. The speed problems went away.

Dont take my input wrong (not saying your doing bad or anything) but if your fps drops cause an animation to take twice as long i would start by stopping the fps drops from occuring (or as best as u can anyway)
You do NOT want to disable the fixed framerate setting, its there for a reason.

Unfortunately I’m in Travel now and can’t test that, but will report back in a week. The strange thing that I’m pointing is… It used to playback the same exact scene in 4.12 correctly, but in 4.13/4.14 I get this slowmo playback. So I’m wondering what happened after 4.12 !

Fixed frame rate is disabled by default in the VR template (and most other templates as far as I can remember)
I set it to fixed at 90 earlier, thinking my performance would be better. Then I unchecked it when I started seeing these weird timeline speed issues.
It seemed to have no effect, except the speed of the timeline became stable.
You can also adjust the fps for each individual sequencer. See if that helps.