UE 4.10 won't compile from sources if bDebugBuildsActuallyUseDebugCRT = true

Hello everyone.
Yesterday I attempted compiling the UE 4.10.2 downloading the corresponding file from Github. I run the usual procedure (setup first, then generate project files) and then tried to compile the “Debug Editor” configuration after setting bDebugBuildsActuallyUseDebugCRT = true in BuildConfiguration.cs.
The compilation failed at the linking stage, when trying to produce the UE4Editor-PerforceSourceControl-Win64-Debug.dll file.
I tried multiple times doublechecking everything and it always failed. Other configurations (DebugGameEditor, Development Editor) compiled just fine.

PS: I also posted this on the forums, sorry for the noise: Compile error with UE 4.10.2 in debug configuration - C++ - Epic Developer Community Forums

Hello .cat,

I can confirm that I’m getting the same behavior when I attempt that. I wanted to confirm however, have you do this in any previous builds of the engine where it worked or is this your first time attempting this?

Hello ,

after facing this issue with 4.10.2 I made an attempt with github release 4.9.2: same procedure, everything worked just fine.
Thank you for taking the time to confirm this.


Thank you for the information, .cat. I’ve tested this in some of our more recent builds, including 4.11 Preview and it doesn’t seem to be occurring any longer. Although it the preview isn’t quite stable enough for us to suggest using for development purposes, the full release should work for you in this aspect.

I also took a look to see if I could find any bug reports related to it so that I could give you a Github commit for it but it seems as though it was fixed inadvertently and tracking it down proved impossible.

Have a nice day!

I am sorry to report that I tried building the 4.11 preview 4 and the error is still there for me. I used the Github file again.

It seems that this issue is only happening with Visual Studio 2015. This explains why I didn’t have the issue when I tried some of our most recent internal builds as they default to 2013 for generating the project files. I’ve reported the issue under the bug number UE-26754 in our system. I hope we can have this fixed for you soon, but in the meantime you should be able to force the use of 2013 if you have it using the generateprojectfiles.bat and build without an issue.

Hello, any news on this? Now that UE 4.12 is out it seems like VS2015 is the only official toolchain. Was this fixed along the road?
If is not reported as fixed I can test it myself during the weekend, I just don’t know when I’ll have time for it.

The issue is currently backlogged and isn’t a high priority at the moment. It may not see any attention for a while. This is partially due to it having a workaround and not being a complete blocker. As far as the workaround, you should still be able to generate project files for 2013 and compile without any issue if you edit the GenerateProjectFiles.bat file to build a 2013 project. I tested this with the 4.12 version available on Github and was able to build correctly on 2013, although it is still failing to build correctly in 2015

Thanks for testing. If there’s a workaround, then it’s fine for me. The only thing I don’t get is the following sentence in the 4.12 release announcement:
“Please note, for C++ programmers on Windows: Unreal Engine now requires Visual Studio 2015.”

That’s correct. That’s honestly the oddest thing about this bug still occurring but not occurring when building with 2013. As of 4.12, even if you use 2013, it will build with the 2015 toolchain so the difference in toolchain must not be what’s causing the build to fail in 2015 but not in 2013.