Ubuntu compiling project

I have been really confused on how to compile the game project for ue4 in linux. SO i have the editor up and running i changed some stuff in the cpp class of my character and when i hit compile in game it gives me an error about not being able to compile and not about an error in code. I dont have vs in linux obviously so not sure how to build the solution file so I am really stuck here and need help

Could you try to use UBT from command line? Here example of Windows, Linux should be similar

D:\UE4\UnrealEngine\Engine\Build\BatchFiles\Build.bat PluginTest Win32 Debug "SolutionDir/ProjectName.uproject"

Also try install code::blocks as i know UE4 supports that

thing is I dont have windows so I am trying to compile natively from ubuntu. I tried that command and doesnt work. Also in code::blocks I can open the sln file but won’t show me the files. Do I possibly need wine to compile or some virtualbox?

What you looking to do is cook your project (as I understand) Cooking on linux - Platform & Builds - Unreal Engine Forums

There is a wiki page also → Cooking on linux - Platform & Builds - Unreal Engine Forums

The problem is that this is a moving target. I too have had no success with this process yet. Though I only have a little time apply to this.
Please let us know what worked.

That was what I was looking for thanks!