UBT Error [4.7.6] & [4.8.0 P1]: Failure to Produce Item: C:\Users\USERNAME\Documents\Unreal Projects\PROJECTNAME\Binaries\Win64\UE4Editor-PROJECTNAME-3843.dll

I have been spending hours and hours on trying to figure this issue out. I can’t add any assets or code without the compiler giving me an error. The log either gives me a ton of errors or just 1 error. Usually when LNK2001 errors pop up, I just recompile and it works. But I have been scratching my head at this one. I can’t even create a new project for 4.7 or 4.8 without giving me the same error. I was trying to replicate the Elemental Demo Torch Asset and Modify it to suit my needs.
I used the Github source code and the regular default install. I tried rebuilding in both Visual Studio and the Programs in both the default bat tools and the Github bat tools.
I can’t figure this frustrating thing out…

link text

I had the same problem, after I updated visual studio.
From Visual Studio try Build → Clean Solution.
This was because the engine libraries were still cached from a build with the old version and were incompatible with new version, or something like that at the linker stage I believe.