TXAA - very bad quality


I am struglling with TXAA. I cant get rid of the noise on my moving objects. The worst is when I attach normal maps (including those from Epic). When I move my object I can see smearing/blurring on my mesh. The material has ONLY normal map and nothing more. If I choose FXAA or None I dont have any problem. It is impossible for me to have any kind of moving object in the scene (with diffuse it is less pronounce but still visible). I tested it with my friend on other machine and it is still the same. Also I found some topics on the web but no answers. Is it really so buggy? How do You people make some movement using TXAA without any problems? I have some wet surfaces and using TXAA is almost impossible. Why?

I think there is no workaround at the moment even recent GDC kite demo shows some smudging from txaa. This method is using data from previously rendered frames witch is causing issue, higher frame rates might reduce effect, getting beast PC is solution for the moment. Personally i tried using FXAA but it is causing another set of problems with highlights on shiny surfaces so you need to keep that in mind when creating materials.

Looks fine for me, but I always maintain a Framerate way above 60. I’m not sure if it’s frame-rate dependant or time dependant, but it does take place over multiple frames. It’s not that UE’s implementation of TXAA is bad quality or anything, it’s just down to the way it works.

I too noticed the smudging in the Kite demo, it’s very apparent around the kite itself and other long straight edges.

It would be useful if you could post some screenshots of the artefacts your seeing though, I don’t see any noise on my surfaces unless they’re moving insanely fast (like, a few hundred units a frame).

No, it is not because of PC. I do have beast PC (2x 970, 16 GB RAM, I-4790K) and having only one object I do have problems. I it really simple to recreate.

  1. Make a simple sphere
  2. Make new material
  3. Search for T_CobbleStone_Pebble or any other normal map with small details (from the StarterContent)
  4. Just attach the normal map in Your material and leave everything alone
  5. Move Your object slowly and You will see the problem.

Another tests I made:

I noticed this in the GDC demo - ugly smearing:

Yes, I made all the changes in ini files and Postprocess. We do make renders of the scenes because we are making cinematics.

I also get that weird effect on any moving objects in my project, regardless of how big or small, how fast they are moving (my tests were with slow-moving objects), or my framerate. It doesn’t like motion blur in particular - reducing motion blur considerably alleviates the issue on slow objects, but something like wings it still is extremely dominant. It looks like ghosting. I am using a 6970.

But I don’t like FXAA or TXAA anyways because they blur the image very noticeably. I just run without AA for now and hope they will fix the blurring eventually or someone produces an alternate AA solution. To me that is the biggest weakness of the engine I have seen thus far.

@Illusionray - That image from the video looks more like motion blur than Temporal AA filtering, either that or the video compression is causing the banding effects. I don’t think that is from TAA though (the edges are smudged a bit, but it’s hard to say how much of that is from the video itself).

In your 2 videos, is the sphere a static mesh or a BSP brush with a material applied? Reason I ask is BSP objects when moved have a bit of a delay that could cause that issue. Also make sure to turn up the SSR quality setting in your global PP volume to 100 (50 by default) to see if that makes a difference.

The sphere is a static mesh but I can use any static mesh and it will be the same effect. Yes, there is a slight compression but it looks alsmot the same in my viewport. It is really very noticeable. I dont know how someone can make a racing games :slight_smile: If You object has more reflections it is very bad. I incireased the Postprocess setiings and also in the ini files I changes the NumRays and NumSteps to 32 in SSR material.

we experienced the same issue for our project as well and since we have a lot of moving things in front of a dark background it is very noticable. FXAA seemed to be the only solution :confused: