Two bugs: Trouble renaming folders in editor, and Starter Content Not Added Automatically

Yesterday I updated from 4.12 on my MacBook Air to the current version, UE4.14.1. Similar problems has happened on 4.10 apparently, and it doesn’t seem like other people has reported it for UE4.14. I have never experienced these problems in previous versions on Mac.

The following problems has been experienced creating a basic C++ project:

1. I cannot rename folders in the vertical menu in the content browser

Similar to another problem in 4.10 according to the answer hub. The same workaround worked for me.

2. Starter Content won’t include itself if ticked

Similar to this workaround for UE 4.10, where one adds the starter content manually after project creation. It starts with a completely empty, untitled map. If you ask for a new map, the three “starter templates” can be selected, even if the starter content has not been manually added yet. Without the starter content it does however only result in creating another new “untitled”, empty map again.

Update: Requested information 30/12/2016

I am running on a MacBook Air 13" (Early 2014). I can’t figure out how to get detailed specs, though.

CPU: Intel i5 1.4GHz

RAM: 2x2GB DDR3

GPU: Intel HD 5000

256 SSD, still around 20% of free space.

OS: Sierra (10.12.2)

Probably not the most suitable system for anything else than minesweeper, but it works for simple things, and I have never had issues with previous versions of UE.
The excluded options during the UE 4.14 installation were "Editor Symbols … ", “Art tools”, and “TVOS” - Starter Content has been installed.

Since I cannot replicate the error today, I can only tell you what I remember doing twice before reporting the problem:

New Project C++ Project (Basic Code) with starter content

It opened without errors, but as mentioned Starter Content was not included (There was no map for it in the content menu either) until I manually included it. A completely empty map was opened prior to adding the Starter Content to the project, but even before, when I asked to create a new map, it prompted me to select between the three choices you also posted a picture of. When I asked for a default map (The first choice) it gave me a map without anything, no platform, no lights or anything.

Renaming folders wasn’t possible in the “vertical menu”, and f2 didn’t work either, I tested that. Renaming in the horizontal menu did work, however.

Hi Brooke,

Please list your Apple System specs in order for us to test on a similar machine. Testing on a MacBook Pro, Late 2013 model produced the following results:

  1. In UE4.14, pressing F2 allows you to rename folders in the Content Browser in any column. This is expected behavior.

  2. Unable to reproduce second bug by following these repro steps:

            a. Open a new project without Starter Content
    
            b. Select File>New Level
    
            c. The following screen appears:
    

120284-newlevel.png

            d. Select "VR-Basic" level

            e. "VRBasic" loads as expected

Be advised that the Starter Content would need to have been included in the Engine version Dowload as shown here:

If these repro steps do not apply to the bug(s) you are reporting, please provide step by step instructions for how to reproduce the bug on our end.

Thanks,

Steve H.

I updated the original question due to the character limit. I don’t know anymore, something tells me it is my computer acting strange since I could not replicate the problem today, but another problem occurred with new projects; Selecting a Basic C++ project with Starter content seemed to work fine until it was done with “creating project”. After this, a new bar popped up with no title. At the beginning 0% some error occurred:

The project could not be compiled. Would you like to open it in Xcode?


Running Mono...

Setting up Mono
/Users/Shared/UnrealEngine/4.14/Engine /Users/Shared/UnrealEngine/4.14/Engine/Binaries/Mac
ERROR: Couldn't find target rules file for target '-project=/Users/***/Google Drive/UnrealEngineProjects/Test/Test.uproject' in rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
Location: /Users/Shared/UnrealEngine/4.14/Engine/Intermediate/Build/BuildRules/UE4Rules.dll
Target rules found:
	UE4Editor - /Users/Shared/UnrealEngine/4.14/Engine/Source/UE4Editor.Target.cs
	UE4Game - /Users/Shared/UnrealEngine/4.14/Engine/Source/UE4Game.Target.cs
	UnrealHeaderTool - /Users/Shared/UnrealEngine/4.14/Engine/Source/Programs/UnrealHeaderTool/UnrealHeaderTool.Target.cs

This can be solved however. Manual building in Xcode, as UE suggests, works fine, and Starter Content is included, the correct map is loaded, and folders can be renamed as supposed.

To make sure it wasn’t just a random error, I have tested three new projects today, and all three of them gave this error.

The system has been quite static since the last time I used UE on it, so I don’t know what could have gone wrong in the system itself, but sorry for the inconvenience if it really is my system’s fault.

I use Xcode version 8.2.1 (8C1002)

Here’s an alternative solution for the error you are getting “Couldn’t find target rules file for target ‘MyProjectName:’”

https://answers.unrealengine.com/questions/13614/couldnt-find-target-rules-file-for-target-myprojec.html

Let me know if it does not resolve your issue.