Download

Tweaking DFAO settings through Skylight has no effect on scene

hi, i’m trying to tweak DFAO settings through skylight, but i’m getting no visible difference on any change. i got “generate mesh distance fields” enabled, skylight is set to movable, Visualize > DFAO does give me a proper visual result, but I can’t get any visual change in tweaking. Any ideas?

Is there a post process volume(s) in the scene?

Yes, there are 2, one is unbound (infinite extent), the other only covers a room.
Here are the AO settings in there, changing these doesn’t have an effect too. I thgouht these were SSAO settings?

It could be because you have RTAO enabled in the post process. I think they can conflict and one stops working when changing settings.

In addition, when you changed the project preferences to “Generate Mesh Distance Fields”, did you restart the engine, or not. In the doc, it reads that you need to restart Unreal for it to take effect.

I don’t have RTAO enabled though, check the screenshot - only the the parameter is enabled, the feature itself is disabled. I’ve tried disabling both PP volumes and then changing DFAO settings, no effect again.
Yes, I have restarted the engine bunch of times after I enabled “generate mesh distance fields” .
Could this be a UE5 bug?

You should disable the parameter for RTAO anyway, though I presume you tried that and it didn’t work. That was somehow the source of the problem for me as I had experienced the same problem in one of the versions between 4.23-4.25. But, since you’ve attempted to delete the PPs, then it’s not that.

If it’s not a bug, and it’s something due to settings, I would guess there’s a chance it could be solved by going to 3 areas:

  1. Project > Preferences > Rendering
  2. cvars in the console
  3. visualization views

For console variables (cvars), try different terms with “ambient occlusion” and “AO”, “occlusion”, “distance field”, “DF” to see what the available options are…and type “?” after each to get a brief description and sometimes what you can change them to (0 or 1 for on/off, 0…1…2…3… represent different values, etc).

For Rendering settings in Preferences, the generate MDFs isn’t the only ambient occlusion setting. If you’re using static lighting, or if you haven’t enabled “Use No Precomputed Lighting”, then the static-based AO settings would probably still be in effect…whether they’re enabled or disabled. So, check those to see if changing one or more fixes it. Another possibility is the scene became stuck in reference to its AO settings, and due to garbage collection or a change in the .ini files it has frozen in a state of no output / results when changing settings. Attempting to enable / disable other settings for AO or closely associated with lighting and the AO could unfreeze things. So could copying the project or level, then opening the copy in a newly started instance of Unreal Engine.

Have you tried searching forums / Q&A for the same problem? If so, and found other potential solutions, did you try those?

Hey, thanks for the in depth reply. Really appreciate your help!

1-
I’m using Lumen with UE5, so I don’t think there should be any static lighting?
While looking for the “use no precomputed lighting” setting you’ve mentioned, I found it under “world settings” and I have it already checked on - but I found a “use ambient occlusion” setting there as well, also tried checking that on but that didn’t have an effect.
I’ve tried straight up unchecking “ambient occlusion” under rendering in project settings, no effect.
I’ve tried turning off and on other ao related settings I’ve found, but nothing seems to work.

2-
I’m trying different cvars like, “r.DistanceFieldAO 1” and 0, has no effect.
“ShowFlag.VisualizeDistanceFieldAO” just shows me the distance fields like in the image above.
I couldn’t figure out properly how to use other cvars like “r.AmbientOcclusion.Method” etc. They also just didn’t have any effect.

3-
Under buffer visualization views, I just get empty white screen for “ambient occlusion” and “material ambient occlusion”. “mesh distance fields” gives me the image above as I’ve said,. I couldn’t find any other relevant visualization view.

Lumen replaces DFAO

Hahah, okay that explainst it. Can’t believe I didn’t know this.
Do you know any way to tweak the Lumen AO? Can’t find anything on this in the documentation.

Not that I am aware of. As far as I know Lumen isn’t art directable at all (in its current state), it just tries to match the path tracer.

I learned this for the first time. I didn’t know Lumen replaced DFAO in UE5. I haven’t worked with UE5 yet. It sounded like a bug after trying all that, though there still could’ve been at least a few other potential solutions. Why not use UE 4.27.2?

I’m using nanite for my project, so I need to stick with UE5, and lumen is also super nice :smiley: