[Tutorial] Error in Visual Studio project

Trying to create a New C++ project by following these instructions:


The editor opens correctly, but Visual Studio (version: Express 2013 for Desktop)

gives the following popup:

One or more projects in the solution have not loaded correctly.

Please see the Output Window for details.

The Error is lengthy (attached here), but an overview:

error : The composition produced a single composition error, with 4 root causes. The root causes are provided below. Review the CompositionException.Errors property for more detailed information.
  1. No exports were found that match the constraint:
    ContractName Microsoft.VisualStudio.ProjectSystem.References.IAssemblyReferencesService
    RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.IAssemblyReferencesService
    RequiredCreationPolicy Shared

  2. No exports were found that match the constraint:
    ContractName Microsoft.VisualStudio.ProjectSystem.References.IComReferencesService
    RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.IComReferencesService
    RequiredCreationPolicy Shared

  3. No exports were found that match the constraint:
    ContractName Microsoft.VisualStudio.ProjectSystem.References.IBuildDependencyProjectReferencesService
    RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.IBuildDependencyProjectReferencesService
    RequiredCreationPolicy Shared

  4. No exports were found that match the constraint:
    ContractName Microsoft.VisualStudio.ProjectSystem.References.ISdkReferencesService
    RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.ISdkReferencesService
    RequiredCreationPolicy Shared

I’ve tried to create a new project with version 4.8.3 also, with the same results.

Tried the same solution in Visual Studio Community 2015, and it loads without any issue.

I also noticed that an error comes up (see below) when WDExpress 2013 loads, which may stem from [this][1] Nuget issue.

Gonna try using VSC 2015 for the time being.

Hello jacob2512,

It seems like the issue may be with the Visual Studio 2013 install itself or the configuration of it. Could you try building a non-UE4 project to see if it results in the same errors?

You’re right!.. strange, i can build existing project, but can’t create any (gives the above error)… maybe it is one of the plugins acting up… will try uninstalling and reinstalling WDExpress 2013

Nope… supposedly this is a known issue



Attempts to reinstall Update 4 (my current ISO version) give the above NuGet errors for me too… Gonna try installing WDExpress 2013 Update 5.

Hello jacob2512,

From what you’ve described, it seems like this may be an issue with Visual Studio or the plugins that you’re using. I suggest speaking to Microsoft customer service or the creators of any third-party plugins that may be causing these problems to occur. I’m unable to assist with issues related to Visual Studio unless it is to do with its compatibility with UE4.

Have a nice day!