Turning off Global Post processing volume turns objects white


I have a problem with my game on low spec PCs where all the objects in my scene look like they are in a heavy thick fog.

I managed to replicate this problem by disabling the ‘post processing volume’ in ‘global post processing’.
I get the same problem when I turn my post-processing quality settings to anything lower than ‘High’.

I found the problem, it was the skybox’s emissive material which got blown out by post effects (or lack of) at lower settings.

Let me know if I should delete the thread. Or if you have an explanation to why that is happening at low settings and not high?