Trying to test my game but can't

For some reason, when I try to test my game from the editor or any other type of way to test it, no character shows up. I’m using the first person template and have never had this problem before. Every time I hit “Play” it spawns my camera under the map and I cant move or anything. The player start is above the landscape and there’s no error. I’ve also tried moving it to other locations with no luck. Anyone else have this problem and find a solution?aa18df081b57b8c11f9ef25a03eec8670490373e.jpeg

1 Like

-check if you have several player starts in your level -> when yes, delete them
-move the landscape and the player start up -> it could be that you are under the kill z volume
-what happens when you do a right click onto the landscape - play or when you press the big play button?

This is likely due to the LOD switching that occurs when you use engine scalability settings lower than high. Go to Settings in the toolbar -> Engine Scalabilty -> set it to Epic and try again.

This is a cut & paste from my answer to the first linked thread below, detailing what I think is causing this issue:

See further here as well:

I’ve tried all options from both of you and noting worked. I haven’t messed with any LOD settings. It was already set to high but i moved it to epic and nothing changed.

Ok I think this will work:

Go into your World Settings panel (Window -> World Settings) and change the “Kill Z” variable to -10000.00 or lower, by default it is set to -1000 which is way to high when using a landscape with height variation. When the player drops down to this position in the level, the game will automatically kill the player, and since you haven’t created any game logic for restarting when killed it just locks the camera in place. It is meant to avoid a situation where the player falls off the edge so that they won’t fall forever.

I just created a new project for a demo level I am doing, and ran into this issue as well, I am pretty sure this should fix your issue. :slight_smile:

Still not working. Any other options? If I delete my landscape and add a new one it fixes it. But I shouldn’t have to Delete my landscape

How large is your terrain? I’m having this issue with a massive landscape. It worked intermittently when I imported it (seemed to work all the time when the level was built and saved), but then I changed to LPV and it wouldn’t work at all. It’s not a problem with the terrain being below the KillZ bound or the player start below the terrain, cuz I don’t think it would have ever worked at all if that was the issue. I noticed that I can eject from the player controller and move around, it changes position, but when I possess I still have no control and the screen gets tinted again.

I made my terrain like 2000x2000. I’m working on an open world game. Should I make my terrain that big or should I use level streaming?

2km by 2km? I don’t know if the size is actually the issue, but I would still use World Composition regardless because it will improve performance. I’m going to mess around with some settings tonight and see if I can fix it.

I set the KillZ down as far as possible (-9999999562023526200000000.0), I still get killed when trying to spawn at low elevation areas. High places work fine, and I can walk down to the base of the map without dying. I don’t know what’s causing it.

Try moving the landscape up on the Z-axis by 10,000 or 20,000 (as well as any other objects in your scene, just select everything), it seems to work just fine as long as the landscape is up high enough. Not sure why this occurs, but that did seem to help in my project.

I opened up that project, moved everything up 7,000 units, and now no matter where I spawn my player it’s always frozen (it’s not rendered, so I guess it’s dead?) thousands of kilometers below the terrain. It’s always the same place with the same rotation too. It’s not even an area underneath where I’m spawning, and it wasn’t offset when the terrain was moved. I used to be stuck a little below it, now it takes a while at max camera speed to fly back up. I set the KillZ back to -20000, didn’t seem to change where I was at.

LPV has stopped working now. Using the visualizer I can see it flicker when moving the camera, but it fades away very rapidly.

Having the same problem. Nothing works, about to give up Unreal.