Trying to save game to E: external reference error

Hey guy’s, I’m getting this error every time I try to create a game on my e drive and go to save the content. Maps and sprites. I keep running out of space on my C drive. I’ll start working on something all of a sudden I’m using about 25-50 gbs of data. I have a lot of free space on my e drive, and I followed this tutorial

I don't know what I'm doing wrong, it's really frustrating. Thanks .

Do you get that error only after you’ve ran out of disk space on your C-drive, or before that as well?

Regarding C-drive disk space usage, UE stores some data in this location:


Particularly “Common\DerivedDataCache” is of interest, it can grow quite large.
You can read more about the purpose of that folder here: Derived Data Cache | Unreal Engine Documentation

Follow the documentation and you can change where that folder is stored, set it to a drive with more capacity.

Related questions:

"Externally referenced error"

This means that some assets are located outside of your content folder, possibly also outside of your project folder. Be careful to not just copy assets from one project to another, use the Migrate function.

It seems fairly common to get this error after converting your project to a newer version of the engine. When I tried to open my project from the launcher, it asked me if I want to open up a copy - it’s been recommending doing it this way, but I still got “externally referenced error” on some assets.

What I did instead, was go into Windows Explorer and my project folder, right-click the .uproject file and select “Switch Unreal Engine version”. Then I receive no errors.

Another workaround suggested, if you have already converted your project and have errors, was to simply rename your project folder to some temporary name, open your project by double-clicking the .uproject file in Windows Explorer, saving, exiting, and renaming the folder back to its original name. Supposedly this has worked out in some cases.

You can also try deleting the folder “intermediate”, which resides in the root of your project folder. Then rebuild.
Another tip is to try the “Fix up redirectors in folder” functionality, just right-click a folder in your project and select that.

Possibly relevant question:

Before too. I have about 40 gb free on my C drive right now, trying to save to E I still get the error.

Is it the same error as described here?

If it is, then there’s mentioned a workaround of renaming your project folder to some temporary name, open your project (just double click your .uproject file), save and exit, then rename your project folder back to its original name again.

Hey Erik, this is the warning that I get.


I’ll try that work around to see if it works.

Thanks for your help, I’m not sure if it’s the same error though, I get this error anytime I create a project on my E drive, a blank project doesn’t get the error until I create any asset, then I get the error, any of the template projects I get the error right away.

if you press “Yes”, what happens? Are you able to open the project?

Well I thought that the map check was telling me that it wouldn’t cook, I just pressed yes and cooked the project and it worked, with my changes, so I’m not sure why I was getting the message, sorry and thanks.

But I did recover 10gb of space thanks to Erik =D

external reference warnings may indicate that you need to run a “fix up redirectors” on your contents folder within the content browser. This will clean up any loose redirects from moving/renaming referenced assets. If this does not fix the error, please post back here and I’ll be happy to take another look.

Thank’s guy’s for all the help with this. I’ll try that. Thanks again for the help.

Hey Erik, I looked at the error from your link.

Any time that I create any starter project except for the blank project on my E drive, I get the error. I can create projects to my C drive but I have 100th of the space to create projects.

I just replaced the references, and preformed a map check and got these warnings.

I appreciate you guy’s trying to help. I’ve run into this error alot and I figured that I had to have all my projects on my C drive then I saw the video on where he had his projects on another drive, so I figured that it was finally time to ask for help, after I did what he did and still couldn’t get it working.

Is it ok to change base engine instead of default engine so that I can do all the ddc at the same time instead of individually?

Ok thanks for all your help Erik, I’ll try that.

Yes, and if you use %GAMEDIR% in the path, DDC will reside in your project folder.

No problem, I hope you’re able to solve the issues you’re having. Are you still on 4.10? It might be a good idea to just try uninstall/remove everything and install 4.11, see if you get the same behavior still.

BTW: What is the path of your engine installation, and in which path do you create new projects?

4.11 Released! - Announcements - Unreal Engine Forums!

With that said, there’s always going to be bugs in 4+ million lines of code :wink:

I’ve had the same issue from the beggining, I’m waiting for the official release of 11. That way hopefully there’s no bugs.

Touche. They do a pretty good job about hunting them down though.

Hey guy’s I figured out the problem.

I was putting brackets in my directory path to move the folder to the top of the list and this was causing the error.

No brackets works perfect.

Hey guy’s I figured out the problem.

I was putting brackets in my directory path to move the folder to the top of the list and this was causing the error.

No brackets works perfect.