Trying to rotate player character (unique; hard to explain)

Update: Video:

First off this is a networked environment.

Here’s an image of the game:

It uses a fixed camera that moves around by itself. The camera isn’t attached to the player via components or anything. I’ve set the camera as a view target and am currently using its view angle to make sure that “up is up” based on the camera rotation. Very simple code: Get camera reference, get its rotation, set control rotation of controller.

BUT HERE’S THE PROBLEM! I can’t seem to be able to rotate my character? I’m trying to make it so that if you push up on the right joystick you look up into the sky. You press down and you look at the ground. Press left and you start rotating left. Press right and you start rotating right. Quite simply it’s the first person example but without the camera. But when I copy paste the code into my own nothing happens. Values go in but no rotation happens.

The alternative idea is to use a standard “Twin Stick” rotation method but even that isn’t working for the same reason. I’ve tried “Set Actor Rotation” but it was rotated 90 degrees (add 90 ezpz) and then flipped o-o ? Like after I rotated it so that pressing down looks “at the camera” and up places the character’s back to the camera NOW pressing left looks right and pressing right looks left.

o-o Any ideas? I’ve also tried “add controller Yaw / Add controller Pitch” to no avail.

What are you trying to make? A platformer where the camera follows the player pawn?

Here’s some older footage:

The camera is working as intended in that video and that’s how it works currently. Just trying to make it so that my player can “shoot” in any direction while also moving in any direction. Currently I’m experimenting with ideas like being able to look up or down in order to affect trajectory of things like grenades or actually aim at weak spots. Typical prototype stuff.

But it’s the aiming that’s not working. I realize that I need an “aim space offset” or whatever for the up/down aiming to work properly; but the turning should be working o-o

Fixed I think. It’s 3:35am though so…