trying to fix my 2k cubemap to look good, how?

After a couple days of work I have a full 2k cubemap imported to unreal.

The texture looks beautiful as far as I can see:

However when I view it in the material editor it looks terrible!

What am i doing wrong? is there something I need to change when I make the dds? (I am using GIMP)

Or is there a change I need to make in the material editor?
In any case, any help would be greatly appreciated.


Change the ‘compression settings’ under ‘Compression’ :wink:

What setting would you sugest? (there are at least 8 choices even in gimp)

Here are my base options that I chose in gimp that work
and these are the compression options available to me in GIMP:
Bc1/DXT1 works but the image is distorted and low res.
I had tried bc3/DXt5 however the asset would not work

Any help Would be very appreciated!

Don’t save it that way, save to PNG or TGA, and then import to UE4 where it will handle the compression.

how do I save the image properly? (I am guessing a multiple page tga or a cube mapped image)
Once that’s done how do I get unreal to take the image?

not having much luck with gimp. I have tried many variations. the only compression setting that works is ‘no compression’
I don’t have photoshop and can’t afford it. the ati cube map gen keeps crashing.
not having much luck with the cube maps is there another way to add skies to unreal 4?


Perhaps is there a way to map a cubemap in unreal with a file other than dds?

For skybox? Yes you can make box, then “spherify” it in 3d application, then apply standard textures to spherified faces. This saves several mb compared to cubemap texture.
Also there are ati and nvidia applications that conversts cubemaps into set of standard textures.

Search for topics and tutorial about creating star skybox, i think it was done with “stargen” app.