Download

Trying to create animations for new assets

So I tried to follow this Tutorial, Unreal Engine 4 Tutorial: Custom Character (english) - YouTube.

It seemed easy enough just to get the ball rolling on this project we need to complete, but apparently, there are issues editing the transitions in with editing the time remaining ratios. From what I heard, this is due to the version of unreal I’m using which is 4.6.1… My question is, if I were to downgrade to an earlier version, could I get this to work?

What exactly is not working? :slight_smile:

The transitions states in the last part for the Jumps… Basically, I’m not able to edit the parts where I have time remaining ratios ala the parts in between the Jump Start, Jump End, and Mid Jump… Those parts are only read only regardless of what I do… Also I get errors regarding the new variables that I added just as the video states… Where he didn’t get those errors… I will provide some screen shots later if you need them…

For the part with editing the Jump start, Jump End… → just delete them and recreate it :slight_smile:
When you tell me which variables you mean, I can go and check it (made this video with 4.2 or 4.3 version of the engine → so it could might be that it’s outdated)

Yeah I think it is… When you I edited the parts of the actual jump start and jump end fine but it will not let me edit the parts in between where I need to put in the asset of time remaining ratios… That is where the problem is… In between the nodes those are read only for some reason… Also I mean the bool and Float variables you added gives me errors as of 4.6.1… But I’m not sure if that’s due to me not being able to edit the time remaining ratio parts or not… I’m pretty much a newb in Unreal Lol…

Yep, you just have to delete and recreate them, after that it will work -> dont know if there is another way how to get rid of the “read only” problem

Which kind of errors do you get + have you named them as in the video + click on the error and see where it jumps to (then we know where the problem is) :slight_smile:

I indeed named them Speed and IsInAir? as you suggested… I will provide you with some screens when I can of the errors I’m getting…

Here are some screenshots for you to review just so you are better informed of the problems I’m having on my end…

f2b086777534675eb73eef47f002a32e.pngd0e9201daed2b3ddf2602c2220c3090f.png


35e3fed642d00191625ffe406797fffaaba0a08a.jpeg

Keep in mind that she doesn’t have a run animation, but she has a touch animation I would like to implement on the EIOs within the game… This means that I set the last two parts on the last screenshot to her walk animation that was provided to me…

Here is another screen shot showing the two variables I included…

I dont know exactly how to solve it (was not abel to reproduce it), but click on the error (in the log box where it says ->…therefore Target must have connection) and post me the location where it appears → because it has nothing to do with the variables :slight_smile:

Here you go

It could be that those errors are caused by the first one in the list, but when you send me your animbp, I will take a look at it → I knew the solution some months ago, but I forgot it and I need it in front of me, because I’m not abel to reproduce your error… :stuck_out_tongue:

It’s also strange that it mentions the HeroTPP_AnimBlueprint in the error.

How about I just send you the whole project? The stuff I edited will be in the shadowbrume folder and all you have to do is type in “test” to see where I made the changes…

You can also do it like that :slight_smile: -> either send me a pm or do it over skype: nasph96

Ok, it works now, dont know what you did wrong, but I just did what I mentioned above -> replaced the links between the different states :slight_smile:

I’m going to test it with an earlier version of unreal engine but, in 4.6.1 it only has her idle animation working…

Simple mistake -> in the anim bp you have to delete the “event blueprint update animation copy” node and replace it with the “event blueprint update animation” node (the other one was a copy, that’s why it was not working. To get this node you just have to do a right click - search for “event blueprint update” and choose the one under the event tab

Can you show me exactly where I have to do this?

Here in your anim bp:

d27a82a51fe5b0d8b9538e393c53cac837966680.jpeg

I got it thanks!!!