Download

Troubles with shadows

I am in very big confusion. I am suffering with this problem a very long time. It’s simple, but with my little knowledge I can’t fix by myself.
I asked on AnswerHub, read all of docs about lighting and shadows.

So, I have a platform, located so high from floor. It don’t cast shadow. There is not so big number of objects on it, which cast shadows. It looks nice, if you staying on platform, but all shadows from all kind of objects (static, movable, doesn’t matter) goes through this platform. They cast shadow on platform, and through it at the same time. It’s really enrage. Please, someone, help me!

There are screenshots with objects’ settings and mystic shadows:

http://imgdepo.com/id/i10166368
http://imgdepo.com/id/i10170614
http://imgdepo.com/id/i10170615

I am assuming that you are using movable directional light. Go to the details tab of the directional light > Cascaded Shadow Maps > Dynamic Shadow Distance Movable Light > Lower the value untill the furthermost shados (on the floor) disappear.

It’s a bad solution for this situation. I don’t want to disguise shadows, I want they don’t go through. I have dynamic objects on my scene and shadows disappear very early, so no.
Are there any other ways?

Hmm, make the material that the background mesh (the floor that is receiving shadows) unlit. Go inside the material editor under the “Material” tab > Shading model > Unlit. :slight_smile:

It’s helped, but I lost a “Volume Effect” of my scene.

9bedf6bc6a7132a6d7d7f38d1f7baba4c4b0d436.jpeg

If the background is going to be just a box, meaning it wont change forms or the likes… The best solution is to bake an AO pass in an outside software (like 3ds max/maya) and use the resulting texture as multiplier for the color while still keeping the material in unlit mode. Tho I tried to use the “Precomputed AO mask” node which you can generate inside the World Settings > Lightmass settings > “Use Ambient Occlusion” - On and “Generate Ambient Occlusion Material Mask” - On > Build light but it didnt worked for me, so you can play more with this too. :slight_smile:

I will try it. Too much thanks, I’m really tired of finding a solution…