Download

Troubles Grooming A Pup in 4.26!

Hey all!
New to hair / fur simulation and have been trying (and failing) to get my puppy’s fur rendering correctly. I’ve successfully followed a few tutorials for getting a standard hair asset from Blender 2.91 into Unreal 4.6, but for some reason, this happens when I import the fur’s alembic file as a groom asset:

I thought the artifacting may have been caused by ticking some wrong settings in Blender’s particle properties, but even after starting from scratch multiple times, it looks perfectly fine until I bring it into Unreal

Has anyone come across this issue before? Any ideas if this is an Unreal or asset creation issue? Some thing I’ve tried:

  • Messing with all the groom import / rendering settings I could find
  • Disabling children interpolation in Blender (to reduce the hair count)
  • Re-creating the vertex groups & hair particles from scratch
  • Re-exporting with modified emitter properties (new hair length, disabled roughness values, etc.)

I’ve been able to import other hair assets without any problems, so I’m thinking it’s probably an asset preparation issue. Just struggling to think of other things to check!

So I still haven’t come up with a solution to this yet, but I have a few interesting updates/developments. I tried a few more iterations of exporting messing with various Blender particle emitter settings (Diameter Root, disabling Close Tip, enabling Long Hair, etc.) but no luck… :frowning:

Because I’ve been able to successfully import other hair assets into Groom without problems, I was thinking the issue had something to do with the mesh I used to create the fur. So I quickly tried creating a new fur in Blender from another puppy mesh I had:

But lo and behold, importing this new fur from a totally different model resulted in the same weird artifacting:

So now I’m lost again as to where the issue lies. It’s curious to me that the Suzanne monkey mesh + hair I created was fine but not the dog meshes + hair I’m having issues with. Maybe it’s something related to mesh complexity?

Anyone else having similar issues?