Download

Trouble with ocean material

I’ve been trying to make a decent ocean, and settled on it being opaque until translucency is improved. I’m having two major problems, one is with the screen space reflections. I feel like they’re way too powerful, all of the clouds are getting mapped onto the plane, which just results in white everywhere. I understand that because the roughness is so low it’s mirror-like, but this doesn’t feel right, I’ll attach screenshots to illustrate. Another problem that I thinks stems from SSR is some odd extremely bright blue coloring, but I can’t tell what causes it. It worsens as you approach a parallel angle to the mesh or look up into it. I don’t think it’s the sky itself, and I don’t think it’s coming from the skylight. My second issue is with the surface, right now I just blend some normal maps, but it’s obviously just rather flat and uniform. I have large scale world displacement which works well, but when I tried for small distortion on the surface I got poor results. The little movements were hard edged and choppy. Is this just a problem with the resolution of my heightmap being too low? It was 512x512 and the transition was very steep.
514af8a397a7263ee013bfef1236d511bc223856.jpeg
0377d88a564f409780c3d5ed42411f7475437e6b.jpeg

Thanks

Hey,

Yeah, unfortunately current rendering system is a bit problematic when creating complex surfaces like water. Had exact same problems when I was porting my ood ocean shader from UE3. What you can do is implementing your own shading model by setting lighting mode to unlit and enabling transparency. You will bypass all standard material parameters like roughness and implement your own params, specific to water shader. some standard nodes will not work, so you will need to create blueprint that will pass most important parameters to your material(light direction for example). Its a bit hacky way of achieving custom lighting models in UE4, but on the bright side, blueprints are so powerfull you should be able to bypass engine’s limitations.

I disabled SSR, doesn’t look realistic to me. Wish there was an option to disable it for specific materials instead of only globally. Changed the normal map too, but still not too happy with it. I think I’ll create a height map by hand for natural movement on the surface. The skylight creates some odd shading, and it looks like some bad noise at a distance. I’m gonna do some more reading on how everything works, I don’t understand it.
791c380a44ba70706661520e08ff1c89e78470f0.jpeg