Download

Trouble with Lightmaps and Interior Scenes

So I recently saw this https://www.youtube.com/watch?v=VcSNuhGUzCE scene in Unity and I wanted to try my best to recreate it, but I just can’t get the lighting to work properly. I’m trying to get good lightmaps for my models and use static lighting mode for them all (except the fan) to get the GI looking as good as it does in the reference scene, but no matter what I try it has horrible bleeding and weird artifacts. I’ve read about every reference I can find on lightmaps, and as far as I can tell I’m following the rules (no overlapping islands, the shapes are proportional, resolution is turned up high, etc) yet these problems persist. Here’s the settings I’m using and the lightmap I have currently

This is just the model I made for the room itself, since I couldn’t get this working I didn’t get around to bringing many other props into the scene.
Here’s what the scene looks like with lighting built at Production quality

My lightmass settings are the default, they look like this

Although I tried someone on the internet’s suggested lightmass settings, they just made the artifacts worse. I hope someone has some insight, I really don’t know how to proceed. I’m probably just missing some key piece of information. Thanks in advance!

Hi!

Ok, so with walls as planes you’ll never get realistic results in Unreal… well if you’re extremely lucky maybe…
So first of all you should rebuild your geometry… Preferable separate walls, snapped at their corners…
The way you can control your lighting:
SLLS (staticlightinglevelscale): basically in cm how detailed you want your lighting to be calculated
NILB number of bounces of lights (except emissive)
NSLB skylight bounces + emissive
ILQ this is the main thing you can get a nicer result BUT it will raise calculating time by a LOT (stay somewhere 4-8)
ILS how much you want Unreal to smooth out (blur) your results… if you want detailed lights, you’ll have to go lower (0.6)
Lightmass compression causes a lot of artifacts!

And one more thing is your lightmap resolution! This is the lighting information in pixels!! If you set a high lightmass calculation but you don’t have the lightmap resolution: you’ll have a poor result…

Just one more thing: the scene from the video, it has a VERY strong AO…

What lightmap resolution should I use? I knew it was in pixels but I saw similar values in the videos I looked up so I thought it was fine. Also for the snapping geometry, can they overlap at all? I also tried building this scene with cubes that overlapped and got similar problems. I’ll try rebuilding them with meshes that perfectly line up though.

Make sure that your Environment color is set to black under World Settings. It looks like you get white color bleed from outside your tunnel.

Well it’s up to you what resolution lighting information you want! Higher will produce more realistic, lower will produce more and more errors… archviz walls have 512 < 4096 per inner face!!
If geometry overlaps or face snapping: you give a chance to have “bleeds” at corners/edges! Lightmaps are pixel maps!! If the texels (you can check in the given view) but it used to be buggy) is not exactly match up with the geometry and an edge is between two texels: you’ll have a “bleed” because it will give an inbetween result… I hope it makes sense…
So NO, don’t overlap them!