Trouble Importing Skeletal LODs from 3ds Max using LODGroups

I have been bashing my head at the wall trying to figure this out as I’ve tried everything I can think of to get UE4 to import skeletal lods from 3ds Max. Troubles range from LODs simply not importing at all (and doesn’t explain why it fails), it imports but it uses the wrong mesh objects/group, or the UE4 Editor crashes. Repeatedly.

So here’s what I’m trying to do: I have a character that is made up of several mesh objects in 3ds Max, each with a unique (not instanced) Skin modifier on it. I did this for both the original objects as well as the lod versions. From what I read on the UE4 docs, I need to take each object, both the base and lod models and put them in a group.

For example, this is what I have setup so tell me if this looks correct:

Not sure if naming them a certain way causes the UE4 importer to react differently but that’s how I have it setup.

Anyhow, I also used the Level of Detail utility directly on the group objects for each LODGroup and it orders them from the most complex (LOD0) to least (LOD1) with the lowest being the one displayed. No idea if this influences which one it imports first based on what’s displayed by default in 3ds Max. Then I take the two LODGroups and the bones they use and export all of then via Export Selected.

So when I import the .fbx file into UE4 (I tried both 4.14 and 4.15), the base LOD imports just fine and it ignores the other lower LOD models (again LOD1). When I go to import LOD1 for the newly imported skeletal mesh, this is where I hit the brick wall and start having trouble. Again, it either fails or imports the wrong LODGroup. Sometimes the editor even crashes when looking at the Skeletal Mesh asset itself, no clue why.

So that’s what I had to deal with so far. If you have any knowledge on what I’m doing wrong, PLEASE let me know. I’ve spent more time on this issue longer than I’d like and, I don’t know about you, the documentation is very sparse on dealing with this type of scenario.

P.S. Personally, I would prefer to just NOT use groups and all that and just import each LOD per set of objects as its own FBX. Saves a few steps and makes it where each LOD is separated in a unique file instead of in the same one. It also seems much more straightforward and universally applicable for most 3d apps.

Looks like I may have answered my own question :P. While I can’t get the LODGroups to work properly, I tried deleting the groups and Level of Detail info and exported each set of LOD objects as its own FBX. For example, I selected all the bones and LOD0 objects and exported that as one FBX and did the same thing with the LOD1 objects.

Edit: Another thing I noticed that can cause an issue is meshes can wind up being treated as bones if you have it as part of the skeleton hierarchy. I had the mesh objects parented to the root control of the character rig which caused this issue. As a result, when importing LODs, it attempts to find said mesh objects and match them against the LOD and fails which causes the entire import to fail as a result.

TL;DR - Don’t parent your mesh objects to the root of the skeleton hierarchy if you’re using LODs.

This worked with no issues whatsoever. The only question I have now is why this method isn’t mentioned in the documentation at all considering it’s a whole lot simpler to do and it just flat out works with no hassle. Would help others out and save them the headache I went through, nearly giving up on using LODs entirely.

Until then, hopefully this solution helps someone.