Trouble configuring game settings

I have been struggling the past couple of days to try and get my game to recognise my GameUserSettings.ini file, no matter what I do it just doesnt work.

I have a production packaged project. (Does not generate a ProjectName\Saved\Config folder)

I have edited my…
C:\Users\user_000\Documents\Unreal Projects\EpicTutorial1\Saved\Config\Windows\GameUserSettings.ini file

But this file does not carry over to my shipping packaging output, and doesnt configure anything in my resulting game.

seems to work for the editor(sort of? doesnt seem to set resolution or graphics settings at all, but recognises fullscreen?)

In anyway this is extremely frustrating, have tried so many things to get a simple configuration to take hold and nothing.

I am optimising this for VR as I am using stereo on, but anything in fullscreen 1080p is unplayable. I need to set the graphics quality to 0 or 1 likely, but cant seem to do it! Thanks

And just a note, before someone tries to answer with this, these dont work for running games, its just for the editor

https://docs.unrealengine.com/latest/INT/Engine/Rendering/Scalability/ScalabilityReference/index.html

and here:

https://docs.unrealengine.com/latest/INT/Engine/Rendering/Scalability/index.html

There are console commands in that documentation for every setting. You can use and execute them in Blueprint, which makes them work in game as well. Just tried Screen Percentage command in a level blueprint and it works.

thanks, that might do it! just altering a few settings like antialiasing and motion blur seem to help significantly with performance, ill use this until theres some better method

Dont suppose you have an example command?

Nevermind! was using something like
r.PostProcessAAQuality=4

which doesnt work you have to type

r.PostProcessAAQuality 4

How do you mean? All of the commands are there. For example, create a Leftmousebutton event, attach it to Execute Console Command node and put r.ScreenPercentage 25 in the command section. Now when you play and hit left mouse button the screen res will be reduced to 25%.

That only seems to work in the editor for me.

What I’m trying to do (as a learning exercise mainly) is to package up Tappy Chicken with lower specs (I was going to put it on the family laptop so my kids would stop asking to play it on my dev comp ;).
No changes I make are reflected in the final package.

I’ve tried manually editing the GameUserSettings.ini and entering commands in the console - it is only reflected in the editor and not in the packaged binary

What am I doing wrong? :frowning:

I haven’t tried packaging a project yet, but this should work just fine.

3103-consolecom.jpg

Set something like this in the level blueprint, set the right mouse button to execute r.ScreenPercentage 25 to test if it works in the packaged game.

I think I get what you were trying to do but still no change anyway :confused:

Not sure who downvoted this dude for that, but he was speaking the truth.

I know it’s a few weeks old, but you need to use the sg settings for most of them to work in game. R.Screenpercentage and the AA seem to work in a built project, but the others didn’t for me. sg.AntiAliasingQuality, sg.ShadowQuality, sg.PostProcessQuality, sg.TextureQuality, and sg.EffectsQuality are the commands that work in a built/cooked project.

edit: and if you didn’t find the settings file for the “Shipped” project, it’s in Appdata. I think Local → yourproject

Well, in fact some commands described in the above ScalabilityReference are working, but ONLY if you use them dynamically, ie. via Blueprints, C++ or using the console…

Awesome explanation! You should make a mini tutorial with this information in the forums. I’ve seen a lot of people curious about creating a settings menu so i’m sure it will be helpful. :slight_smile:

My reference for the following tests is the “Quick Settings” menu described by the blog post on [How to Improve Frame Rate Through Video Settings][1]. This menu we provide 7 group settings that does affect rendering inside the Editor (but not in a Launched/Packaged Game):

Here is the result I want to get:

4360-ue4editorscalabilitysettings.png

Theoretically, a game could use the 7 corresponding commands described int [the Scalability Reference][3], but they are currently not (all) working.

I’ve tested them with the console, and in fact only individual settings are known to the console; group commands are not recognized and do not work. Here is the list of the 7 commands;

  1. r.ScreenPercentage 25
  2. r.ViewDistanceScale 0.4
  3. r.PostProcessAAQuality 0
  4. r.PostProcessingQuality 0
  5. r.ShadowQuality 0
  6. r.TextureQuality 0
  7. r.EffectsQuality 0

Only the 3 first are known and working in the console; they are in fact individual settings, whereas the 4 others are groups of multiple individuals settings (defined in the config file BaseScalabitity.ini).

But thanks to @amiserablerobot I’ve found the corresponding 7 working commands;

  1. sg.ResolutionQuality 25
  2. sg.ViewDistanceQuality 0
  3. sg.AntiAliasingQuality 0
  4. sg.PostProcessQuality 0
  5. sg.ShadowQuality 0
  6. sg.TextureQuality 0
  7. sg.EffectsQuality 0

And thanks to @Jacky, here is how I configure the all settings to their minimum:

To test it, just set all settings to anything above “Low”, than “Play” the Level, and then check in the menu that all settings has been set to “Low” like in the first image.

Cheers!
SRombauts

Edit: posted here as a “documentation bug report” [Scalability Reference does not apply to standalone Game][5]

Thanks, I’ll do that

This is brilliant, thanks!

In the file named “%LOCALAPPDATA%/[APP-NAME]/Saved/Config/WindowsNoEditor/GameUserSettings.ini” add a section similar to:

[ScalabilityGroups]
sg.ResolutionQuality=10
sg.ViewDistanceQuality=0.1
sg.AntiAliasingQuality=0
sg.ShadowQuality=0
sg.PostProcessQuality=0
sg.TextureQuality=0
sg.EffectsQuality=0

Tested with UE4.5.1 on a shipping build.

HI i have a packaged game to my android , i want to set the r.SetRes or r.screenpercentage before the game start but the GameUserSettings.ini is getting clear after every launch in my android so is there are any way that i can set these setting before my game launch ?

btw when i execute command r.SetRes in the game my screen get cropped with black boarder in the side and not getting the right fit so any reason why ?

note : my android is mali400 galaxy beam .

Mhnoni,

I would highly suggest that you look over the Documentation that’s provided. Here is a link, that was provided earlier about [Scalability References][1]. I believe that if you wanted to create a way for the game to start up with those settings, you should set them within a blueprint, or even have a settings menu for the consumers.

If you have any additional questions or concerns, please create a new thread in [AnswerHub][2] for additional assistance. Don’t forget to utilize our [forums][3] as well!

Thanks!

Scalability Reference for Unreal Engine | Unreal Engine 5.1 Documentation
[2]: https://answers.unrealengine.com
[3]: https://forums.unrealengine.com/forum.php

This is the only way to decrease graphics on a packaged build on android for example ? I mean its UE4.12 now and can’t we do it via settings - toolbar without Blueprint?