Tree with Leaves - Crazy Ambient Occlusion

I tried making a custom tree mesh with branches/leaves that are just planes with textures on them, both on my own and using SpeedTree, and I keep getting this result:

I’m using Distance Field lighting, and the AO goes super wack on these leaves. Is there a way to disable Ambient Occlusion on the leaves, or some better method?

I’m new to materials, and the ones from the open world demo are beyond me.