Download

Tree Leaves Disappearing (upgrade from 4.14 to 4.15)

Hello, I’m using the new forward renderer (with MSAA) and just upgraded from 4.14 to 4.15 for some of the new features. However I’ve noticed after this update that tree leaves are all of a sudden fading out at a very short distance. This is extremely noticeable because when looking into the distance all you see are dark trunks and branches with very faint leaves all around them.

I’ve tried making adjustments around the PerInstanceFadeAmount in various leaf materials but it seems nothing fixes the problem. Now since this happened to a bunch of different assets from the marketplace it leads me to believe this isn’t an issue with the individual assets themselves and instead needs to be fixed in the post process or engine settings. I know there are culling distances you can set for foliage but these are just static meshes with two-sided foliage materials in them so I haven’t found any settings to fix this issue.

Any help would be greatly appreciated. Thank you.

In 4.15 ‘alpha to coverage’ is a new feature. Try adjusting the alpha clip value in your masked materials.

Thank you for taking the time to help. In the material settings I see an option for “Opacity Mask Clip Value” which is something I tried adjusting previously. It defaults to 0.3333 and I can turn it down to 0 but this only changes the cutoff value of the fade itself. So with it set to zero the leaves will continue to render even when the opacity is below 0.3333 but this doesn’t do anything about the fade itself.

eb3f86e186789c4fc4436f998ee91cdcfe6235c2.png

Perhaps you’re talking about a different setting? Or is there some way to disable this “alpha to coverage” completely? Or a place where I can adjust the distance settings of the fade being applied to masked materials?

Alright now that I knew what to search for I came across the following post:

https://answers.unrealengine.com/questions/556469/415-p2-msaa-and-alpha2coverage-problem.html

It looks like this is an issue with 4.15 that others are experiencing as well.

I would just like to note that after 4-5 years this issue is still not fixed. There was an actual bug report filed and of course that disappeared without ever actually being addressed. Telling people to jack up their opacity mask values is not a proper solution, this rendering feature should be in parity with the rest of the engine…

The thing is, they had no problem advertising “Robo Recall” to claim UE4 had full VR support with MSAA. In fact, after that they had an entire section on the homepage at unrealengine.com that outlined the “forward renderer” and MSAA support as a major selling point of the engine.

However, for years, while being advertised on the homepage, the documentation for the forward renderer clearly stated that it was an “experimental feature” and should not be used in any production scenario. But they just recently changed it so that message is no longer there, yet not a single update has been made to the forward renderer in YEARS…which begs the question, what prompted the notification to be removed?

I mean all the “not supported” features haven’t changed since 2017, such as no shadowing for any translucent materials, and no MSAA support for D-Buffer decals. This means you don’t see shadows on glass or water. And it means you can’t realistically utilize any particle effects or decals since they will create a disgusting white border around anything in front of them.

So which is it? Is it a fully supported feature suitable for advertising on your homepage? Or is it an experimental feature that is not fully finished?

Since they had no problem FALSELY ADVERTISING this feature, and something such as switching engines to say Unity or Godot is not easy to do, especially after spending YEARS investing into a product…it’s almost as if this was a bait and switch.

Anyone interested in getting together with our lawyer to put together a class action lawsuit? If so, check out the tracer interactive website for our company legal contact information.