Download

Tree-leaves disappear in distance

Hey there,

I’ve made trees with planes as leaves and unwrapped them. I created simple leaves and branches using a PNG-File with transparency. I applied the leaves-material to my tree and everything looks fine. But as soon as I am further away, the leaves start to disappear (they fade out). What could be the problem? It does happen with and without LOD versions of my model. Material without opacity works fine!

27d4eb89fc1a67e23b6a997184ab9ef6496ba6de.jpeg

7b12b55dced6cd3dff0a98f4b12bc4febd3082fc.jpeg

Edit: My leaves-material

f6f366d3617aae0e29006b9ed2b019dba57aae89.jpeg

Looking forward help!

Shame there has been no help on this topic… i have the same problem…

(I’m sorry for my bad english) Hello, I don’t know if it can help someone but me and my friends had the same problem, I think the problem is that you have too much of the same type of foliage to load for the viewport. You need take off a part of them, and you could create a new instance of trees to replace the ones you will take off.

The automatically generated mip maps for the texture are becoming so small and blurred that the leaves completely fade away.

There’s a few options that may help

  1. Try adjusting the Clip Value on the material details.

  2. Create an LOD and use a different material/model when the asset is that small on screen.

  3. Create the texture/material in a different way, consider making the leaves bigger.

Yup, definitely texture mips. There is also a “max alpha” setting on your texture that you can boost up to help fight this.

Hey,

I actually have the same issue. From what I’ve found creating custom mipmaps gives the best results when it comes to foliage. Couldn’t find any info on importing custom mipmaps though. Any clue?

You might try to import DXT texture, that should get in your custom made MIPs… Not 100% sure if this works in UE.

Why don’t you disable Mips or change the LOD Mip Bias?

Performance drops.

Hashed alpha testing is one solution:

i have the problem too,just a translucent mesh

Thanks, that really helped a lot! :slight_smile: