TRASHCLASS compile errors when overriding custom events

Below are error messages presented every time editor is opened.

  • One or more blueprints has an unresolved compiler error, are you sure you want to Play in Editor?
  • Error This blueprint (self) is not a TRASHCLASS_GrabBase_62, therefore ’ Target ’ must have a connection.

These errors only appear when launching PIE with instances of blueprints that, in their event graphs, call custom events from a parent blueprint. Strangely, compiler errors are resolved by simply clicking Compile button on parent class that created event, despite fact that it already shows a clean, error-free compile. Below is a picture of erroneous node in child.

This issue only appeared after upgrading from 4.8 to 4.9. We would like to maintain use of custom events, instead of overloading function calls. While recompiling parent blueprints is not a big deal, it gets tiresome to do so every time editor is opened, and for every single parent class that defines custom events.

Thank you.

I’d just like to say that I am also experiencing this issue with a project upgraded from 4.8 to 4.9.1.

We are also facing this issue and haven’t yet found a way to solve it. As palistov didn’t explicitly ask a question, I will:

How can we solve this issue and avoid recompiling perfectly working BPs to be able to Play a level? :slight_smile:

Hi all,

I’ve moved this post into Bug Reports sections and assigned a member of our staff to look into issue. If they have any questions, they’ll post them here. Thanks!

Hi everyone,

I attempted to reproduce this but I haven’t been able to get same results. Could anyone provide a small test project that has issue?

Hi everyone,

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information.



I am also having a similar issue, but not upgrading from 4.8 to 4.9 (just using 4.8).

@TJ I realise this isn’t a lot to go on, but it is very hard from our end to work out a repro - it seems to be caused by inherited blueprints, (mine at least a blueprint structure) and events, but beyond that, fact that it compiles if you press compile suggests there isn’t some obviously incorrect setup.

If you want to pull my project and investigate, DM me, but it certainly isn’t a minimal project by any stretch of imagination.

Hi ,

I’m limited in ways I can pull projects from outside sources. If it’s something you can PM me a link over Forums to download, that’s fine. However, I’m not able to connect to any outside source control in order to get it.

Is it possible to make a stripped down version that has error?

I tried and wasn’t able to recreate it. I can’t remember what might have caused it prior to our migration to 4.9 but I do recall it only happened afterwards, in my case. I have suspicions that class renaming may have contributed; I’ve never seen TRASHCLASS related errors before that.

Hey @TJ I am having this problem as well, and I think I’ve found a way to reproduce it.
( following is all in blueprints only)

  1. make a class (I called mine “GenericItem”)
  2. make a custom event in that class, with some functions and stuff executing from it (mine just has print string)
  3. make a child class of that class (I called mine “GenericWeapon”).
  4. make that child class override parent class’ (“GenericItem”) event with some different functions
  5. make a child class (I called mine “Shotgun”) from that second class (“GenericWeapon”)
  6. make that child class (“Shotgun”) override same event that both parent (“GenericWeapon”) and (grand?)parent (“GenericItem”) class have
  7. make child class (“Shotgun”) call a reference to parent function (right click on overriden event and select “Add call to parent function”) and attach it
  8. save/compile all blueprints and close editor.
  9. reopen editor. once it has reopened, final child class (“Shotgun”) should have a compile error. Recompiling base class (“GenericItem”) fixes all errors.

Hi BananaGoMoo,

I just attempted to reproduce this in 4.9.2 but I couldn’t get compile error. Is this version that you are using?

If so, could you post a small test project with issue for us to test internally?


I originally started project in 4.8.3 and used launcher to convert it to 4.9.0 and now I’m on 4.9.2. So maybe follow steps 1-4 in 4.8.3 and then upgrade project and continue steps after that. I can’t really upload my project since its pretty large now (well I could but it would take a while). If you want me to, I’ll upload that and pm it to you.

Hmm, I still couldn’t get your results. I’m thinking it could be a conversion error. Have you tried recreating class and it’s children from scratch?

Also, try reproducing it in a new project.

@TJ I will attempt to create an example project this weekend, will post here when I have an update for you.

EDIT: I just tried remaking class, but it still does same error.

@TJ is there a way I can PM you? I’d like to send you project but I don’t want it public.

Yeah, you can PM me directly over Forums. Just send me a link to download project.

@TJ I sent a pm.

Hi BananasGoMoo,

I’m sorry that it’s been a few days. I was able to reproduce issue in project you sent.

I would also like to reproduce it in newest release 4.10 to see if it still happens. I attempted to convert your project but so far I haven’t been successful. Could you give it a try and see if it is still happening there?

We have also encountered this problem and moving to 4.10 has not fixed this issue for us


Hi, All conversion did was change supported version in INI file from 4.9 to 4.10 No other files were modified. It should convert fine if you do that.

And yes, it is still having same problem.