Transparent materials render infront of closer translucent materials

Hi, if you look in the image below, you can see the back faces displaying in front of front faces. This happens only when creating Materials with translucent as far as I know.

There’s more information about my issue in this post here: Proper use of Opacity? Translucency bug? - Content Creation - Unreal Engine Forums

There is a similar bug that happens when using Maya’s High Quality or Viewport 2.0 rendering and it is as far as I know due to the Radeon video card. I don’t get this issue with an nVidia card.

Is this a video card bug, can this be rectified or am I doing something wrong?

For context, the object that is transparent is just a single cylinder with one glass material with an opacity map over the diffuse map. The other objects are not using the same material.

Hello,

Could you please post a screenshot of your material’s setup? Do you have it set up to be two-sided? That can cause what you are seeing. You may want to try using a Masked material instead if that is the case.

Please let me know if that helps.

Cheers!

Hi thanks! It’s set up as translucent with 2 sided on. The back gets flipped to the front. I’m using translucent because I need some mid values between 0 and 1.0 to get some good ‘grime’ going.

Masked transparency is fine, but the threshold is usually 1 or 0 rather than values in between.

If this isn’t the correct method, what is the best way to get that ‘grime’? Right now, I’ve separated ‘glass’ from my object to take in a glass material but I’m still having the ‘flipping’ problem.

Thank you for your patience, I apologize for the wait. I was able to reproduce and verify this issue. I talked with our developers, created a report and assigned it out. It is currently assigned to our lead rendering programmer. A fix will be available in a future release.

Thanks!

Is this resolved yet. I have the same issue on engine 4.4.3 with Radeon 7770.

This is a deeply rooted rendering issue. We are working on creating a feature to switch rendering priority, but it will take a little time. We do not expect this to be implemented by 4.6. Let me know if you have any questions.

Thanks. Take your time guys, doing great work!

I’d like to second the opinion that this would be a great feature.

It’s rendering the engine unfit for hair :wink:

It’s actually driven me to the mobile renderer where translucency, for performance reasons, is out of the question - where opacity masks is really the only option.

This of course leads to solid anime style hair :confused:

Really really hope you can get this sorted soon.

Awesome project none the less!! Not sure I’ll be able to emphasise that enough without eventually boring you.

hi,

is there any update on this? I’m trying to render hair oldschool with alpha masking and it looks bad :slight_smile:
the alpha (even if image is blurry) ends up being super sharp;
and on translucent the alpha looks great, but I get the same problem as described above + the hair looks brightly lit even if in shadow.

We have plans to address this issue, but it will take some time to implement the fix. The visual error is not due to a bug, but the way forward renderers work, so we have to create a unique solution for this limitation. Stay tuned to the blog and engine news updates for details as they come.

Cool that you are working on a fix. Is this going to make it into 4.7 or 4.8 ? I have this issue aswell and have to fall back to masked materials.

Also, some of the comments online seem to suggest this is mainly for water issues. I’m having trouble with some simple translucent surfaces that I have to sort every time away from the camera as they are large and set their translucent render priority every tick. Will the solution apply generally to large objects and have a reasonable cost for an entire level or be restricted?

In 4.8 you will have the option to enter r.ForwardLighting into your engine’s ConsoleVariables config file. That will cause the engine to switch rendering methods.

It will be very experimental at that time and not tested, so unexpected results may occur. Over time we hope to thoroughly implement and support this option.

Is there a way to fix this problem in 4.11? I still have this problem.

Have you attempted the suggested fix Alex P. provided?

Did everything you suggested in this thread. I have a scene where a translucent smoke particle is rendered behind a translucent sky-box for some reason :confused:

Hey D’Arcadius,

Can you provide me with some screenshots so I can visualize what you are reporting as well as some steps so I can reproduce this issue on my end?

Be sure you have enabled ‘Separate Translucency’ on your particle system’s material, and then you set it to have a higher priority than your Skybox so it renders in front.

Thank you,

Andrew Hurley

This is with my ghosts and 0 and my fog at 100, yet ghosts are still rendering as in front of the fog.

Can you show me the materials for both the fog and your ghosts?

They both need to be using Translucency and have the ‘Separate Translucency’ setting within the materials properties.

Depending on which actors you want to render in front of one another, you will need to set the Translucent Sort Priority to a higher number. Things with a lower sort priority like (0.0) will render behind translucent objects that have a higher sort priority (1.0).

Let me know if you have additional questions.

Thanks,

Andrew Hurley

I experience something similar. Going to post my problem as it is much more visually noticeable.